NWN2 - La Chope sans Fond

Le patch 1.22 est disponible

Répondre
Partager Rechercher
Je pense que pour patcher, l'auto patcher doit auparavant trouver les fichiers des patch précédent dans un répertoire. Malheureusement, j'ai bine peur d'avoir fait le ménage.
La question est :
Ou puis-je trouver les fichier des patch précédent
Ou est ce répertoire ou sont conservé les patch.

Merci.
Citation :
Publié par Simkim
Pour ceux qui veulent tenter un téléchargement manuel, il y a les patchs sur cette page.

Pour rappel (si je ne fais pas erreur) :
- pc correspond à NWN2 seul
- pcx1 correspond à NWN2 + MotB
- pcx2 correspond à NWN2 + SoZ ou NWN2 + MotB + SoZ
Je testerai ce soir.
Merci pour le lien des patchs Chandler, je ne l'avais pas trouvé attendant la mise à jour de ce post ou sont réunis tous les patchs. (Pourquoi créer un nouveau post plutôt que MaJ celui-ci ?)

J'ai re-téléchargé les patchs à partir de ton lien et mis à jour le post des patchs FR donc ça devrait rouler maintenant

Par contre, j'ai remarqué une chose au passage, le patch 1.22.1586 >> 1.22.1587 existe aussi pour NwN2 seul et NwN2 + MotB.
Citation :
Publié par Etienne C
Je pense que pour patcher, l'auto patcher doit auparavant trouver les fichiers des patch précédent dans un répertoire.
Je ne pense pas que ce soit ça

Citation :
Publié par Etienne C
Ou puis-je trouver les fichier des patch précédent
- Sur le Vault

- Sur ce post


Citation :
Ou est ce répertoire ou sont conservé les patch.
Une fois téléchargé, les patchs sont stockés ici :

C:\Program Files\Atari\Neverwinter Nights 2\temp

Je précise qu'ils sont stockés dans ce dossier dans le cas ou tu as coché la case Sauvegarder les fichiers patch téléchargés sur l'updater, le cas échéant je ne sais pas comment ça se passe

http://www.lyncya.fr/images/upload/1235742649temp.JPG
Salut à vous


Je viens signaler une nouvelle erreur.
J'ai effectuée la mise à jour en 1.22 tout à l'heure sur mon PC et sur le serveur.

En ce qui concerne mon PC, j'ai utilisé le programme nwn2patcher et la récupération manuelle des .zip sur le vault. J'ai activé l'undo de nwn2patcher au cas où. Aucun problème à signaler.

Pour le serveur, j'ai installé les patch via l'autopatcher du jeu. Là, problème. Impossible de lancer quoi que ce soit une fois en version 1.22.1587, le jeu ou le serveur.

Le message indiqué est que la configuration du programme est incorrecte.

J'ai utilisé les undo de mon PC pour faire revenir en 1.21 le serveur, et hop ça remarchait.

J'ai de nouveau patché, mais cette fois ci avec NWN2patcher et les .zip (comme j'avais fais sur mon PC) mais ça n'y fait rien, le serveur ne supporte pas la 1.22.

Si quelqu'un sait quel fichier est responsable de cette erreur, merci de me prévenir. En attendant, le module est inaccessible pour ceux qui sont en 1.22 -.-'

Edit:

Configuration de mon PC:
OS: Windows XP pro
proco: intel core 2 duo E8500

Configuration du serveur:
OS: windows serveur 2003
Proco: intel Xeon 3070
Kylban, j'ai lu quelque chose qui se rapprochait de ton souci sur cette page du forum officiel (premier message et un peu plus loin par le même posteur).

Le patch 1.22 nécessiterait le framework .NET 3.0, là où auparavant le 2.0 suffisait. Sur la plupart des PC des joueurs, il a de forte chance d'être présent (mises à jour auto, applications en ayant besoin, etc.), par contre sur un serveur...
Merci Elf, j'avais le même problème, a savoir que le jeu ne voulait plus se lancer et le voila résolu suite au passage du .net en 3.5 (j'étais en 2.0)

C'était donc bien ça. (:
Une courte synthèse de deux problèmes que l'on peut rencontrer sur la mise à jour en 1.22 :
  • La mise à jour s'est bien déroulée, mais le jeu ne se lance plus : les différents .exe (lanceur : NWN2Launcher.exe, serveur : nwn2server.exe...) plantent lorsqu'ils sont lancés, avec un message de type "Configuration du programme est incorrecte".
    => Le patch 1.22 nécessite apparemment au minimum le framework .NET 3.5, là où les précédents patchs et le jeu d'origine ne nécessitaient que le 2.0.
    Plus d'infos : forum officiel.
  • La mise à jour est interrompue due à l'absence du fichier nwn2server.exe.
    => Si vous possédez l'antivirus NOD32, il semble qu'il détecte un virus dans le fichier nwn2server.exe et le place en quarantaine. Il faut réaliser la mise à jour en désactivant NOD32, ou récupérer le fichier depuis la zone de quarantaine. Une réinstallation du jeu n'est pas à exclure si le fichier a été modifié par NOD32.
    Plus d'info : forum officiel (et pages suivantes)
Citation :
Publié par Elf des coquillages
=> Si vous possédez l'antivirus NOD32, il semble qu'il détecte un virus dans le fichier nwn2server.exe et le place en quarantaine. Il faut réaliser la mise à jour en désactivant NOD32, ou récupérer le fichier depuis la zone de quarantaine. Une réinstallation du jeu n'est pas à exclure si le fichier a été modifié par NOD32.
Plus d'info : forum officiel (et pages suivantes)
[/LIST]
Il faut faire une réinstallation, NOD32 est à l'origine de tout mes problèmes
J'étais dans le même cas qu'Argyl en 2.0 mais par prudence comme lui je suis quand même passé en framework .net 3.5

Sait on jamais... au cas où... Mieux vaut prévenir que guérir.


Et, comme le souligne Mythyzyn, un grand merci à toute la communauté nwn présente ! J'apprends beaucoup avec vous
Je n'arrive toujours pas à patcher à cause de cela

Version erronnée du fichier détectée sur votre système.
La mise à jour ne pourra pas être effectuée car le contenu du fichier est incorrect.
C:/jeux/Neverwinter Nights 2/Campaigns/Neverwinter Nights 2/ Campaign_X2co_chir.UTC
Taille du fichier : 22124
Checksum du fichier : dc449ed0a37f9ec62c4dca569f60a3ad

Je ne comprend pas quel est le problème sur ce fichier.
Lequel dois-je télécharger....?

J'ai NWN2 avec les deux extensions installées, soit en langage Atari : pcx2, si j'ai tout compris.

Je suis actuellement en 1211549, et le vault ne me propose que ça :

Citation :
nwn2_pcx2_french_from1201541_to1211549.zip => trop vieux

nwn2_pcx2_frenchvofix_from1201541_to1201541.zip => ça correspond à quoi, au correctif des voix, non ? SI c'est le cas, j'ai déjà.

nwn2_pc_french_from1211549_to1221586.zip

nwn2_pcx1_french_from1211549_to1221586.zip

Ca, ce doit être le deuxième "sous-patch" si j'ai bien compris...
Citation :
nwn2_pcx1_french_from1221586_to1221587.zip

nwn2_pc_french_from1221586_to1221587.zip

nwn2_pcx2_french_from1221586_to1221587.zip


-------------------



Hop hop hop !!

Autant pour moi, le site du vault n'a pas l'air tout à fait à jour, et j'ai réussi à attraper le patch sur le lien de Simkim
Autant pour moi !
Répondre

Connectés sur ce fil

 
1 connecté (0 membre et 1 invité) Afficher la liste détaillée des connectés