WAR - Forum technique

Lancement du jeu trés long

Répondre
Partager Rechercher
Bonjour,
je poste pour savoir si tout le monde a le même souci que moi c'est à dire une fois rentré le mdp le launcher cherchant une mise à jour, il faut entre deux et trois minutes pour que je puisse cliquer sur "jouer"?
Suis je le seul à avoir ce problème?
Le jeu mettez beaucoup de temp au debut que j'y ai joué quand j'avais que 1go de ram.
J'ai actuellement 3go de ram , et le jeu se lance bien plus vite , ainsi que les temp de chargement ou les rez par exemple.
Citation :
Publié par Zaraki Hirano
Le jeu mettez beaucoup de temp au debut que j'y ai joué quand j'avais que 1go de ram.
J'ai actuellement 3go de ram , et le jeu se lance bien plus vite , ainsi que les temp de chargement ou les rez par exemple.
J'ai aussi 3 Go et d'ailleurs je n'avais pas ce probleme là au tout début de la bêta.
Pareil,

Au démarrage du patcheur, "début de la mise à jour" pendant 5 minutes avant de proposer le bouton jouer.
Et ensuite pour obtenir l'écran des persos, j'ai le temps de lire les crédits en entier :x
Voilà ce que j'ai tiré du fichier de logs du répertoire logs justement :

Je me demande si y a pas un truc qui cloche dans un fichier de config, et le jeu cherche à aller patcher là ou il a pas besoin.

Citation :
[2008/09/19 00:16:35] libpatchclient initialized.
[2008/09/19 00:16:35] Currently running as [D:\Jeux\Warhammer\warpatch.exe]
[2008/09/19 00:16:36] Currently running as [D:\Jeux\Warhammer\warpatch.exe]
[2008/09/19 00:16:36] Notification of restart with alternate filename
[2008/09/19 00:16:36] libpatchclient initialized.
[2008/09/19 00:16:36] Currently running as [D:\Jeux\Warhammer\warpatch.bin]
[2008/09/19 00:16:36] Nothing to patch for [EAMythic Patcher]
[2008/09/19 00:16:51] NetworkManager::HandleCloseConnectionResponse: sequence numbers don't match: res [2] != active [3]
[2008/09/19 00:17:02] NetworkManager::HandleCloseConnectionResponse: sequence numbers don't match: res [3] != active [4]
[2008/09/19 00:17:13] NetworkManager::HandleCloseConnectionResponse: sequence numbers don't match: res [4] != active [5]
[2008/09/19 00:17:24] NetworkManager::HandleCloseConnectionResponse: sequence numbers don't match: res [5] != active [6]
[2008/09/19 00:17:35] NetworkManager::HandleCloseConnectionResponse: sequence numbers don't match: res [6] != active [7]
[2008/09/19 00:17:46] NetworkManager::HandleCloseConnectionResponse: sequence numbers don't match: res [7] != active [8]
[2008/09/19 00:17:57] NetworkManager::HandleCloseConnectionResponse: sequence numbers don't match: res [8] != active [9]
[2008/09/19 00:18:08] NetworkManager::HandleCloseConnectionResponse: sequence numbers don't match: res [9] != active [10]
[2008/09/19 00:18:19] NetworkManager::HandleCloseConnectionResponse: sequence numbers don't match: res [10] != active [11]
[2008/09/19 00:18:30] NetworkManager::HandleCloseConnectionResponse: sequence numbers don't match: res [11] != active [12]
[2008/09/19 00:18:41] NetworkManager::HandleCloseConnectionResponse: sequence numbers don't match: res [12] != active [13]
[2008/09/19 00:18:52] NetworkManager::HandleCloseConnectionResponse: sequence numbers don't match: res [13] != active [14]
[2008/09/19 00:19:03] NetworkManager::HandleCloseConnectionResponse: sequence numbers don't match: res [14] != active [15]
[2008/09/19 00:19:14] NetworkManager::HandleCloseConnectionResponse: sequence numbers don't match: res [15] != active [16]
[2008/09/19 00:19:25] NetworkManager::HandleCloseConnectionResponse: sequence numbers don't match: res [16] != active [17]
[2008/09/19 00:19:27] Nothing to patch for [Warhammer European Release]
[2008/09/19 00:19:27] Patch Operation Complete.
J'ai un début de solution, j'ai été sur la faq officielle du jeu : http://www.war-europe.com/#/news/?id_news=fr160&lang=fr

Et remarqué qu'il disent d'ouvrir les ports 80, 6881 à 6889 et 6969

Je l'ai donc fait sur mon routeur netgear.

J'ai maintenant dans le fichier patcher.xxxx.log :

Citation :
[2008/09/20 06:30:40] Nothing to patch for [EAMythic Patcher]
[2008/09/20 06:30:54] NetworkManager::HandleCloseConnectionResponse: sequence numbers don't match: res [2] != active [3]
[2008/09/20 06:31:05] NetworkManager::HandleCloseConnectionResponse: sequence numbers don't match: res [3] != active [4]
[2008/09/20 06:31:16] NetworkManager::HandleCloseConnectionResponse: sequence numbers don't match: res [4] != active [5]
[2008/09/20 06:31:27] NetworkManager::HandleCloseConnectionResponse: sequence numbers don't match: res [5] != active [6]
[2008/09/20 06:31:38] NetworkManager::HandleCloseConnectionResponse: sequence numbers don't match: res [6] != active [7]
[2008/09/20 06:31:49] NetworkManager::HandleCloseConnectionResponse: sequence numbers don't match: res [7] != active [8]
[2008/09/20 06:32:00] NetworkManager::HandleCloseConnectionResponse: sequence numbers don't match: res [8] != active [9]
[2008/09/20 06:32:01] Nothing to patch for [Warhammer European Release]
Le launcher ne met plus qu'1 mn contre 2 mn 30 avant.

J'ai quant même envoyé un message a goa pour leur demander si il n'y a pas un autre port a ouvrir ou un autre paramétrage à faire.

Là ça deviens quant même moins génant et en plus la liste des serveur apparait bien plus vite une fois le chargement fait.
En fait fausse joie, là j'essaye de me logger, et ça met autant de temps qu'avant, la seule chose que je voit comme différence c'est que c'est pas la même heure.

Je me demande si le serveur réponds bien assez vite.
Tiré de la FAQ du site officiel de Warhammer online


Citation :
Quels sont les ports nécessaires pour WAR?

Le trafic internet sous le protocole IP passe par certains ports. Normalement, un programme local initialise la communication avec un serveur sur certains ports. Ce serveur est ensuite autorisé à renvoyer des données sur ce même port. Pour qu'un serveur initialise la communication avec un programme local, un routeur a besoin de relever les ports utilisés par la machine pour ce programme. Cela signifie qu'habituellement vous ne devriez pas avoir besoin d’ouvrir de port pour jouer à WAR. Si vous avez tout de même des problèmes, vous pouvez essayer d’ouvrir le port 4574. Pour savoir comment ouvrir des ports sur différents routeurs, veuillez vous référer au site www.portforward.com.
Port UDP ou TCP?

Citation :
J'ai un début de solution, j'ai été sur la faq officielle du jeu : http://www.war-europe.com/#/news/?id_news=fr160&lang=fr

Et remarqué qu'il disent d'ouvrir les ports 80, 6881 à 6889 et 6969
Euh j'ai pas trouvé les mêmes renseignements que toi et même question: ports UDP ou TCP?

Par contre j'ai configuré mon pare feu windows xp pro en suivant les consignes de la FAQ officielle de Warhammer online:

Citation :
Comment dois-je configurer mon Firewall pour WAR?

Si vous avez des problèmes pour vous connecter à WAR, c'est peut être que votre pare-feu bloque le client de WAR. Si vous utilisez le pare-feu de Windows, voici comment autoriser le client de WAR: Cliquez sur le bouton Démarrer. Cliquez sur Panneau de Configuration. Selon le type de bureau vous avez choisi d'utiliser, suivez les indications appropriées: bureau par défaut Windows XP: Cliquez sur Centre de Sécurité. Puis cliquez sur Pare-feu Windows. Bureau Windows Classique: Cliquez sur Pare-feu Windows. Vérifiez que le bouton est bien sur Actif (recommandé) et vérifiez que la case "Ne pas autoriser d'exception" soit décochée avant de continuer. Cliquez sur l'onglet exceptions. Cliquez sur Ajouter un Programme. Cliquez sur le bouton Parcourir. Ajoutez le fichier Warhammer.exe. Puis cliquez le bouton Ouvrir pour ajouter le fichier à la liste. Cliquez Ok. Cliquez encore sur le bouton Ajouter un programme. Cliquez deux fois sur Ok. Répétez la procédure pour les fichiers warpatch.exe et warpatch.bin.

Ça commence sérieusement à me gaver de devoir attendre 10 minutes avant de pouvoir jouer à chaque fois.

Je suis en train d'analyser les fichiers du jeu parce qu'il a crashé et qu'au redémarrage plus aucune touche de raccourcis clavier ne fonctionnait...
Suite à l'analyse et à l'ajout des programmes cités si dessus (war.exe, warpatcher.exe et warpatcher.bin) dans les exceptions du pare-feu windows xp pro, j'ai été agréablement surprise de voir que mon problème fut résolu.

Tellement surpris que je trouve ça louche...

Je vous tiens au courant et j'espère que ceux qui ont le même problème que moi pourront le résoudre aussi.
J'ai le même soucis, j'ai désactivé le firewall de windows, j'ai ouvert les ports sur le routeur mais rien, toujours plusieurs minutes d'attentes.

Extrait de patcher.100508.Log
[2008/10/05 10:47:08] libpatchclient initialized.
[2008/10/05 10:47:08] Currently running as [D:\jeux\Warhammer Online - Age of Reckoning\warpatch.exe]
[2008/10/05 10:47:09] Currently running as [D:\jeux\Warhammer Online - Age of Reckoning\warpatch.exe]
[2008/10/05 10:47:09] Notification of restart with alternate filename
[2008/10/05 10:47:09] libpatchclient initialized.
[2008/10/05 10:47:09] Currently running as [D:\jeux\Warhammer Online - Age of Reckoning\warpatch.bin]
[2008/10/05 10:47:09] Nothing to patch for [EAMythic Patcher]
[2008/10/05 10:52:40] Nothing to patch for [Warhammer European Release]
[2008/10/05 10:52:40] Patch Operation Complete.

et de system.log
[08/10/05][10:53:48]Authenticating.
[08/10/05][10:55:14]Getting server list.
[08/10/05][10:55:15]Getting character list.

On y voit bien deux pauses inexplicables.
kikoo la foule

toujours pas de soluce ? ca devient longuet et pénible d'attendre

1 heure devant soi on peut a peine jouer 10 min

Enfin bon j'ai pas retrouvé de fil plus récent donc je me permet de rajouter ici, écrit a goa mais pas de news font les morts sur le coup, suis surprise car d'habitude très réactif à répondre...
J'avais posté ca à l'époque via le formulaire du site war .. même pas eu de confirmation ...
Ce qui m'énerve dans tout ça c'est que tout les autres jeux (y compris DAoC du même éditeur/distributeur)que j'ai eu entre les mains ont très bien marché sans que j'ai à ouvrir quelques ports que ce soit.
Et la même en les ouvrants ça marche mal.


C'est ca aussi que je ne comprend pas non plus, un port c'est ouvert ou fermé.
Ca marche ou ca marche pas, faudra qu'on m'explique le 'ca marche au bout de 10mn'
Répondre

Connectés sur ce fil

 
1 connecté (0 membre et 1 invité) Afficher la liste détaillée des connectés
Rechercher
Rechercher:

Recherche avancée