DAoC - Général

Calculateur de SpellCraft V 1.7.7 pour LotM en Francais (Retour de l'executable)

Répondre
Partager Rechercher
Citation :
Publié par Ssiena Samedisþjófr
je pensais avoir tout effacé et réinstallé, mais j'ai du faire une bétise parce qu'en l'instalant dans un autre répertoire (qui est donc forcement vide) ca refonctionne, merci
J'avais bien tout viré aussi, mais en changeant bêtement le nom de répertoire d'install, çà re-fonctionne bizarrement. Tu l'aurais pas dit jamais j'y aurais pensé merci Ssiena un shoushi avec le reg?
Citation :
Publié par Zup Arkhen
J'ai fais la MAJ vers la .16 tout à l'heure mais comme à chaque mise à jour j'ai des problème cette fois-ci le programme plantait régulièrement. Encore une fois obligé de le désinstaller pour le réinstaller.
Avant chaque lancement de mise à jour je lance un banc de test sur mes machines (une dizaine allant du windows 95 à Vista) et pour le moment je n'ai jamais réussi à reproduire ce bug.

Citation :
Publié par Feant / Luriikiki
J'avais bien tout viré aussi, mais en changeant bêtement le nom de répertoire d'install, çà re-fonctionne bizarrement. Tu l'aurais pas dit jamais j'y aurais pensé merci Ssiena un shoushi avec le reg?
Le programme ne se base absolument pas sur la base de registre pour fonctionner.

Je ne sait pas si ces problèmes sont liés mais si les personnes qui rencontrent ces soucis sont dans le même cas de figure que Ssiena (c'est à dire plusieurs versions de python et plus problématique plusieurs versions de la bibliothèque graphique), il se peux que cela engendre des soucis dans le code de programme.
Le fait de se retrouver avec plusieurs versions est sûrement due au fait que plusieurs installations du programme ont été faite dans la même arborescence. En fonction des versions majeures mise à disposition je signalais qu'il fallait bien supprimer le programme précédent, hors il se peux que d'anciennes versions qui utilisaient l'ancien installeur ne se soit pas supprimées entièrement (laissant entre autre les fichiers précités).
Depuis la version 1.5 (et l'utilisation du nouvel installeur) le faite de lancer la suppression enlève tout les fichiers correctement mais pas les fichiers présents en version antérieure à la 1.5 qui eux ne peuvent être enlevé que manuellement.
C'est pour cela que je préconise de désinstaller le programme et supprimer tout les fichiers qui pourraient rester à la racine d'installation du programme (hormis les répertoires items et templates ainsi que les fichiers spellcraft.xml et database.db) avant de faire toute nouvelle installation. (Ou plus simplement mais moins proprement réinstaller le programme dans une nouvelle arborescence).
ben je pensais avoir tout effacé sauf mes objets et mes templates avant d'installer la 1,6 (en général, quand le programmeur me dit que ca marche mieux en effacant d'abbord, je ne m'amuse pas a faire le contraire ) mais je l'ai remis dans le meme répertoire qu'avant, hors apparement, j'aurai mieux fait de m'abstenir

cela dit, c'est pas grave, c'est réparé, j'ai compris comment faire si ca se reproduit et donc c'est tout bon

j'en profite pour signaler qu'il y a un piege dans les nouveaux casque skinné, ils n'ont pas forcement les memes bonus que les bandeua de base
Hjalmvaeng avec Liens Runiques donne 5% soin (c'est le casque a ailes valkyrie en maille) au lieu des 5% défence fournit par le bandeau de meme nom

je n'ai encore testé que les casques a ailes, mais il faudrait peut-etre tester les autres aussi du coup
Citation :
Publié par Nephystos Fahrenheit
Par contre, pourquoi je n'arrive pas a charger les items du pack de Kaar ?
Tu veux dire via l'interface "Charger Objet" qui te renvoie directement au contenu du répertoire xxxxx/Calculateur de Spellcraft/Item/realm ( l'1 des 3) ou tu parles plus de mise à jour de base de données via la commande : module de recherche> charger base de Données ?

Moa Cht'i Scout
Encore bravo, j'utilise abondamment ton logiciel et il est vraiment super.

Deux remarques, en espérant ne pas répéter :
- la version des bottes du Danseflamme pour le séide n'est pas la bonne.
- certains items de la 1.88 comportent plus de 10 emplacements de gemmes, ce qui aujourd'hui n'est pas possible.
Hop je viens de faire la maj vers la .16 et au désespoir, le programe plante au démarage.

Voici un extrait du "exe.log"
Code:
Traceback (most recent call last):
  File "SearchingCombo.pyc", line 91, in keyPressEvent
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc0 in position 1: ordinal not in range(128)
Traceback (most recent call last):
  File "SearchingCombo.pyc", line 91, in keyPressEvent
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc0 in position 1: ordinal not in range(128)
Traceback (most recent call last):
  File "SearchingCombo.pyc", line 91, in keyPressEvent
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc0 in position 1: ordinal not in range(128)
Traceback (most recent call last):
  File "SearchingCombo.pyc", line 91, in keyPressEvent
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc0 in position 1: ordinal not in range(128)
Traceback (most recent call last):
  File "SearchingCombo.pyc", line 91, in keyPressEvent
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc0 in position 1: ordinal not in range(128)
Traceback (most recent call last):
  File "SearchingCombo.pyc", line 91, in keyPressEvent
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc0 in position 1: ordinal not in range(128)
Traceback (most recent call last):
  File "SearchingCombo.pyc", line 91, in keyPressEvent
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc0 in position 1: ordinal not in range(128)
Traceback (most recent call last):
  File "SearchingCombo.pyc", line 91, in keyPressEvent
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc0 in position 1: ordinal not in range(128)
Traceback (most recent call last):
  File "SearchingCombo.pyc", line 91, in keyPressEvent
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc0 in position 1: ordinal not in range(128)
Traceback (most recent call last):
  File "SearchingCombo.pyc", line 91, in keyPressEvent
slt et tout d'abord merci pour ce beau calculateur sc

je suis actuellement en version 1.6.10 et quand je fait la maj vers la 1.6.16 le prog plante quand je veux le relancer.

J'ai 1 fenêtre qui pop où ca me marque:
"errors occurred
see the logfile 'c:\program files\calculateur de spellcraft\calculateur de spellcraft.exe.log' for details"

Je te copie le logfiles

Code:
Traceback (most recent call last):
  File "Calculateur Spellcraft.pyw", line 82, in <module>
  File "Calculateur Spellcraft.pyw", line 69, in start
  File "ScWindow.pyc", line 154, in __init__
  File "ScWindow.pyc", line 1091, in calculate
  File "ScWindow.pyc", line 1352, in getItemImbue
TypeError: object of type 'int' has no len()
Traceback (most recent call last):
  File "Calculateur Spellcraft.pyw", line 82, in <module>
  File "Calculateur Spellcraft.pyw", line 69, in start
  File "ScWindow.pyc", line 154, in __init__
  File "ScWindow.pyc", line 1091, in calculate
  File "ScWindow.pyc", line 1352, in getItemImbue
TypeError: object of type 'int' has no len()
Traceback (most recent call last):
  File "Calculateur Spellcraft.pyw", line 82, in <module>
  File "Calculateur Spellcraft.pyw", line 69, in start
  File "ScWindow.pyc", line 154, in __init__
  File "ScWindow.pyc", line 1091, in calculate
  File "ScWindow.pyc", line 1352, in getItemImbue
TypeError: object of type 'int' has no len()
Traceback (most recent call last):
  File "Calculateur Spellcraft.pyw", line 82, in <module>
  File "Calculateur Spellcraft.pyw", line 69, in start
  File "ScWindow.pyc", line 154, in __init__
  File "ScWindow.pyc", line 1091, in calculate
  File "ScWindow.pyc", line 1352, in getItemImbue
TypeError: object of type 'int' has no len()
Traceback (most recent call last):
  File "Calculateur Spellcraft.pyw", line 82, in <module>
  File "Calculateur Spellcraft.pyw", line 69, in start
  File "ScWindow.pyc", line 154, in __init__
  File "ScWindow.pyc", line 1091, in calculate
  File "ScWindow.pyc", line 1352, in getItemImbue
TypeError: object of type 'int' has no len()
Traceback (most recent call last):
  File "Calculateur Spellcraft.pyw", line 82, in <module>
  File "Calculateur Spellcraft.pyw", line 69, in start
  File "ScWindow.pyc", line 154, in __init__
  File "ScWindow.pyc", line 1091, in calculate
  File "ScWindow.pyc", line 1352, in getItemImbue
TypeError: object of type 'int' has no len()
Traceback (most recent call last):
  File "Calculateur Spellcraft.pyw", line 82, in <module>
  File "Calculateur Spellcraft.pyw", line 69, in start
  File "ScWindow.pyc", line 154, in __init__
  File "ScWindow.pyc", line 1091, in calculate
  File "ScWindow.pyc", line 1352, in getItemImbue
TypeError: object of type 'int' has no len()
Traceback (most recent call last):
  File "Calculateur Spellcraft.pyw", line 82, in <module>
  File "Calculateur Spellcraft.pyw", line 69, in start
  File "ScWindow.pyc", line 154, in __init__
  File "ScWindow.pyc", line 1091, in calculate
  File "ScWindow.pyc", line 1352, in getItemImbue
TypeError: object of type 'int' has no len()
Bon courage pour la suite,
byou.

vucan
Mise à jour du programme en 1.6.17.
Pour la liste des corrections veuillez vous reporter au post initial. (entre autre dans cette version, la modification du code concernant la mise à jour du programme afin d'éviter les erreurs de téléchargement).

Pour les personnes ayant (ou qui rencontrons des soucis de mise à jour, il est nécessaire de télécharger de nouveau le programme en entier - exe ou rar -), lors des futurs mises à jour de la version 1.6.17 à supérieur il ne devrais plus y avoir de soucis.
La version 1.7 continue dans de bonnes conditions mais au vu des changements engendrés (c'est à dire une remise à zéro du code une bêta publique sera sûrement mise en place).
Bonjour,
J ai exactement le même problème que Ssiena page 5 provenant de qtcore4.dll... malheureusement moi, même après créé un autre dossier, puis avoir tout effacé correctement , avoir passé ccleaner etc.... je n'obtiens aucun résultat, le programme ne s'ouvre qu'au démarrage après l 'installation et ensuite erreur windows.... Je ne sais plus que faire...
Up du post pour vous signaler que je ne suis pas mort

Le peu de temps libre que j'ai actuellement ne fait que retarder la mise en place de la nouvelle version qui prendra en compte les modifications de Daoc en version 1.89.

La plus grosse partie du codage est maintenant terminée et je m'attaque aux nouvelles fonctionnalités qui m'ont été demandées. C'est pourquoi je ne me suis pas préoccupé de mettre à jour le calculateur en version 1.6 ces derniers temps.

J'espère pouvoir mettre en ligne assez rapidement la version bêta de la 1.7, qui sera pour la première fois en bêta publique vu le nombre de changements effectués.
En attendant je vous met à disposition un screen du calculateur dans son état actuel.

PS : Si une personne se sent l'âme a faire un set d'icônes (Format png taille 16x16) pour les accès rapides aux modules (charger Objet, Sauvegarder Objet, Créer Objet, Effacer Objet, Effacer tout le craft) qu'il ne se fasse pas prier, les icônes mis actuellement pour ces modules sont sûrement améliorable.

Bon jeux à vous.
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom : Scdaoc1.7.JPG
Taille : 1024x738
Poids : 112,1 Ko
ID : 22836  
ah enfin la possibilité de faire plusieurs SC simultanément, ca commence a devenir de plus en plus interessant à utiliser
manque plus que quelques fonctionalités de Loki pour que je l'enterre définitivement
Répondre

Connectés sur ce fil

 
1 connecté (0 membre et 1 invité) Afficher la liste détaillée des connectés