Optimisation (ArcheAge - Forum technique)

Problème texture Direct11 Nvidia

Répondre
Partager Rechercher
Salut, si j'ouvre ce topic, c'est pour parler des problèmes liés aux textures qui ont du mal à charger en jeu. Un problème lié aux cartes graphiques Nvidia plus ou moins récentes apparemment.

Il y a cette solution (à l'étape 2) : http://archeage-ressource.fr/config.php

Mais en ce qui me concerne, le problème persiste et je crois que je ne suis pas le seul.

Que ce soit avec DirectX 9 ou 11, les textures ne charges pas correctement et parfois ça donne ceci :

http://imagizer.imageshack.us/v2/280x200q90/661/QSGLqy.jpg http://imagizer.imageshack.us/v2/280x200q90/538/HRWJKE.png http://imagizer.imageshack.us/v2/280x200q90/633/N3FpRZ.png http://imagizer.imageshack.us/v2/280x200q90/537/wpwRB6.png

Si je pouvais transformer ce post en TUTO, je le ferais, mais pour le moment c'est compliqué

Je me dis qu'il doit y avoir un problème avec les étapes expliquées dans le lien citer plus haut, avec par exemple l'histoire du "lecture seul" coché/décoché.

D'ailleurs, pour l'étape 1, il vaut mieux utiliser PhysX avec le GPU pour ceux qui ont une bonne carte : http://www.nvidia.fr/object/nvidia-physx-faq-fr.html)


Ce que j'ai fait :

J'ai bien remplacé le "system.cfg" par le nouveau dans \Mes Documents\ArcheAge\

Après c'est là que je me suis peut-être planté, j'ai mis le contenu du nouveau dossier "bin32" (DLLs DirectX11) dans les originaux de la version beta et alpha. Mais il me semble que c'est bon, enfin bref..

En gros ça donne ceci : Glyph\Games\ArcheAge\Alpha\Bin32 et Glyph\Games\ArcheAge\Beta\Bin32.

Puis lecture seule du "system.cfg" décoché, lancement du jeu, changement de résolution (ça nous met d'office une basse résolution qu'il faut changer), j'ai quitté le jeu et fermer le luncher et enfin j'ai remis en "lecture seule".

Et donc, ça ne fonctionne pas.


 

Ici je mets l'étape 2 en question :


Optimisation 2 : Le vrai directX 11.

Lorsque vous installez pour la première fois ArcheAge, vous constaterez que le DirectX11 est une émulation du directX10. Voici comment optimiser votre jeu avec le vrai directX11 :

1. Installez les DLLs DirectX11 dans le dossier Glyph\Games\ArcheAge\Bin32.

2. Placez le fichier system.cfg dans le dossier \Mes Documents\ArcheAge\, puis retirez le mode lecture seule, redéfinissez votre résolution d'écran, sauvegardez et remettez la lecture seule.

3. Votre Jeu est désormais sous le vrai pilote DX11. Pour les Nvidia, vous pouvez également installer Nvidia Inspector, recherchez dans la barre le jeu ArcheAge, puis activer l'option "toggle fxaa on".




Si quelqu'un peut apporter quelques précisions pour essayer de résoudre ce problème, ce serait d'une grande aide merci.
Les problèmes ne sont pas qu'avec des NVIDIA.

J'ai essayé le jeu avec ma GTX 460 et ma 7950 HD et j'ai le même problème :
- des textures qui mettent un temps fou à apparaitre et/ou restent en very low
- des personnages qui disparaissent de partout, du coup je vois même pas les symboles au dessus de leur tête
- à la connexion, et de temps en temps, j'ai carrément aucune animation de mon personnage : il glisse (les autres personnages risquent pas, ils n'apparaissent pas... lol)

Donc je pense que ça vient plus du processeur qui suit pas ou de la RAM.
J'ai 4 Go de RAM et un core2duo bas de gamme (je peux pas préciser je suis pas sur mon pc là)
En very low, ça attenue beaucoup le problème mais bon foutre du very low sur une 7950

La technique du Dirext11 marche pas non plus, il me dit qu'il y a un problème avec le fichier D3DCompiler_42 et la case DX11 reste tout le temps grisé alors que je suis sous Vista et à jour

Bref le jeu est quand même le plus buggé techniquement auquel j'ai joué depuis très longtemps.

Dernière modification par Watchy ; 27/08/2014 à 10h13.
Citation :
Ce que j'ai fait :

J'ai bien remplacé le "system.cfg" par le nouveau dans \Mes Documents\ArcheAge\

Après c'est là que je me suis peut-être planté, j'ai mis le contenu du nouveau dossier "bin32" (DLLs DirectX11) dans les originaux de la version beta et alpha. Mais il me semble que c'est bon, enfin bref..

En gros ça donne ceci : Glyph\Games\ArcheAge\Alpha\Bin32 et Glyph\Games\ArcheAge\Beta\Bin32.

Puis lecture seule du "system.cfg" décoché, lancement du jeu, changement de résolution (ça nous met d'office une basse résolution qu'il faut changer), j'ai quitté le jeu et fermer le luncher et enfin j'ai remis en "lecture seule".

Et donc, ça ne fonctionne pas.


En ouvrant le fichier...



Citation :
-- [SYSTEM CONFIGURATION]
-- WARNING! THIS FILE IS GENERATED BY THE SYSTEM! EDITING IS NOT RECOMMENDED!

sys_spec_full = 4
sys_MaxFps = 60
r_driver = "DX11"
r_multithreaded = 1
r_windowx = -1
r_windowy = -1
r_width = 1920
r_height = 1080

r_fullscreen = 1
r_vsync = 0
r_multiGPU = 2
login_first_movie = 0
ucc_ver = 2
auto_disconnect_timer = 30

e_Tessellation = 1
r_TexturesStreamPoolSize = 1024
r_WaterTessellationHW = 1
r_TessellationMaxDistance = 60
r_TessellationTriangleSize = 8
r_ssao = 0
r_ssdo = 2
r_SSReflections = 2
r_Sharpening = 0.40
r_HDRBloomRatio = 0.20
e_GI = 1
e_GICache = 6
e_LodRatio = 40
e_MergedMeshesInstanceDist = 15.0
e_MergedMeshesViewDistRatio = 60
e_ParticlesForceSoftParticles = 1
e_ParticlesObjectCollisions = 2
En rouge ce qu'il faut changer je crois bien et non en jeu (sinon le jeu doit se remettre en Dx10 dès que tu le lance et qu'il n'est pas en lecture seule).
Merci pour vos réponses, je n'ai pas modifié la résolution dans le fichier, donc je vais faire ça merci.

Sinon, en fouillant un peu, j'ai vu que cette méthode ne fonctionner plus depuis l'une des mises à jour apparemment.

Je vais attendre la sortie et je verrais bien, un patch officiel se serait bien quand même.
Citation :
Publié par Watchy
...

Donc je pense que ça vient plus du processeur qui suit pas ou de la RAM.
J'ai 4 Go de RAM et un core2duo bas de gamme (je peux pas préciser je suis pas sur mon pc là)
En very low, ça attenue beaucoup le problème mais bon foutre du very low sur une 7950 ....
Non rien a voir avec les performance du procs ou de la ram, j'ai un pc avec i7 , 8 go de ram et un gtx760/2govram ...même résultat. Les textures sont mal chargées après 5 min en dx11 et ça fonctionne un peu mieux en dx9 mais les textures mettent quand même du temps a se charger (mais au moins elles se chargent).

(L'astuce pour forcer les dx11 natif est a priori plus bonne.)

Reste plus qu'a espérer qu'ils corrigent ce bug visuel désagréable qui est quand même assez rédhibitoire pour un jeu qui met en avant ses qualités graphiques... maintenant il est aussi possible que l'open beta fasse tourner une version dégradée , ça c'est déjà vu des mmo qui tournaient mal en beta et hop d'un coup mieux a la realease... à suivre donc.




Je ne sais pas si le coup du DX11 natif fonctionne ou non, mais en tout cas suivre l'ensemble du procédé a au moins réglé ce problème de textures chez moi.
Citation :
Publié par Alindiras
Reste plus qu'a espérer qu'ils corrigent ce bug visuel désagréable qui est quand même assez rédhibitoire pour un jeu qui met en avant ses qualités graphiques... maintenant il est aussi possible que l'open beta fasse tourner une version dégradée , ça c'est déjà vu des mmo qui tournaient mal en beta et hop d'un coup mieux a la realease... à suivre donc.
C'est surement Nvidia qui chie dans la colle avec son pilotes puisque sous AMD ça fonctionne normalement sans besoin de faire quoi que se soit.

Et donc très peu probable également pour la "version dégradée".
J'ai une carte graphique AMD haut de gamme (R290x), avec proc et ram de qualité, et j'ai exactement le même problème de textures gros pâté comme dans les screens du 1er post. J'ai essayé à peu près tout ce que je pouvais faire, y compris régler tout en basse qualité, supprimer le répertoire shader et j'en passe, ça n'a rien changé.
J'ai bien essayé la méthode du vrai DX11 mais je n'ai vu aucun changement ni amélioration d'aucune sorte... Du coup je suis vraiment dans une impasse, avec mes pilotes à jour etc.
Je vais réessayer la manip a la release mais sinon je ne vois pas. A noter que chez moi, les textures grossières apparaissent immédiatement dès que je suis log.
Bonjour,

Je n'y avais pas tellement prêté attention jusqu'à présent et en voyant la première image avec cette brume que parfois j'ai la même chose.

Vous dites que ce que je prenais pour de la brume voir une tempête de sable n'est qu'on beug graphique dû à ma GTX 560 TI ? - Bon je l'ai pas souvent, mais bon...

--
j'avais voulu augmenter l'antialiasing dans le panneau de config Nvidia et ca m'avait fait le meme Bug, j'ai donc TOUT laissé géré par le jeu et desactivé le panneau de config nvidia et hop les textures sont redevenue net ! ne surtout pas augmenter le mipmap ou le FXAA
Citation :
Publié par Mackdolphin
j'avais voulu augmenter l'antialiasing dans le panneau de config Nvidia et ca m'avait fait le meme Bug, j'ai donc TOUT laissé géré par le jeu et desactivé le panneau de config nvidia et hop les textures sont redevenue net ! ne surtout pas augmenter le mipmap ou le FXAA
J'ai noté aussi une incompatibilité avec les réglages du panneau nvidia... et je ne suis pas sur a 100% mais il me semble que ce bug est apparu/empiré après avoir ajouté Archage dans la liste des jeux gérés par le driver....

Pour la release je vais supprimer la référence Archage du panneau Nvidia et voir si ça ne marcherait pas mieux à tout hasard....

Citation :
Publié par Alindiras
J'ai noté aussi une incompatibilité avec les réglages du panneau nvidia... et je ne suis pas sur a 100% mais il me semble que ce bug est apparu/empiré après avoir ajouté Archage dans la liste des jeux gérés par le driver....

Pour la release je vais supprimer la référence Archage du panneau Nvidia et voir si ça ne marcherait pas mieux à tout hasard....
Je pense comme toi ! Après avoir fait les modifications dans le panneau de config. Nvidia, le flou (en sprint) devient marron et certaines choses choquent ! Je l'ai donc enlevé, à voir demain maintenant...
Salut à tous,

J'ai le même soucis !

J'ai fait déjà tout ce que vous avez fait.

J'ai même utilisé nvidia.inspector qui permet de changer les settings plus en profondeur.

Rien à faire. Toujours ce bug de textures.

J'ai dû cumuler sans mentir 8 heures dessus.

J'en ai ma claque, j'ai jamais passé autant de temps à gérer des problèmes graphiques sur un jeu.

J'ai l'accès anticipé j'ai quasi pas pu en profiter pour le moment...

Il faut dire qu'à la base j'avais un problème de FPS qui chutait gravement. Le jeu tournait avec le chipset du pc portable. Impossible de changer le processeur et prendre celui de Nvidia.

C'est comme ça que j'ai connu nividia.inspector qui m'a permis de supprimer le profile "Archeage" Nvidia et de prendre manuellement le fichier .exe. Ce n'est qu'ensuite que j'ai pu changer le processeur.

Et maintenant c'est les textures qui ne se chargent pas.

Le pire c'est que j'avais réussi à régler le problème mais au bout d'un moment dans le jeu, genre bien 10 à 15 minutes de jeu, certaines textures ne se chargent pas puis ça devient de pire en pire.

Bref. Si quelqu'un a réussi à trouver un truc, je suis preneur


EDIT : Pour l'info, j'ai deux ordis qui utilisent Nvidia. Sur l'autre je n'ai aucun soucis. La seule différence entre les deux sont la carte graphique, le fait que ce soit une tour et pas un portable, ET la mise à jour de la carte graphique.

Sur la tour je n'ai pas encore mis à jour ma carte graphique qui est "GeForce 337.88". La mise à jour du Portable est la plus récente. Donc on va essayer de downgrade la mise à jour. Je vous tiens au courant...

Dernière modification par Icanebal ; 14/09/2014 à 14h16.
Citation :
Publié par Icanebal
Le downgrade de mise à jour n'a servi à rien...
Salut Icanebal,

As tu essayé de passer le jeu en Directx 9 dans les options d'Archeage.

Pour moi cela a résolu le problème de chargements des textures, dans la zone de départ des Firrans.

++

Dernière modification par Cochontetram ; 14/09/2014 à 21h20.
Citation :
Publié par mrshawn77
j'ai eu le probleme aussi, j'ai remis le system.cfg d'origine et je n'ai plus de probleme.
gtx 770
Après avoir cherché dans tous les sens, j'ai utilisé le curseur de réglage par défaut (paramètre qualité bas, normal; haut, tres haut, utilisateur).

J'ai donc mis sur très haut et sélectionné Dx11 et la plus de soucis de texture et mes fps sont revenus au niveau de mon 1er jour en beta (30/35 fps ... avant avec les textures buggées j'était a 23...et parfois 13 dans certains coins).

Donc conclusion : ne pas régler les graphismes individuellement ca doit être buggé... plutôt utiliser le réglage global sur une valeur prédéfinie.

Bon maintenant je suis confronté au crash du client dont il est question dans un autre poste...
Citation :
Publié par Cochontetram


Salut Icanebal,

As tu essayé de passer le jeu en Directx 9 dans les options d'Archeage.

Pour moi cela a résolu le problème de chargements des textures, dans la zone de départ des Firrans.

++
Salut

Oui j'ai oublié de préciser ce détail...

J'ai essayé en Directx 9. J'ai eu une session a peu près "normale". Y'avait eu moins de bug de textures (seulement un carré vert à la place du cercle de sélection). Mais voilà, une fois sur deux, j'ai des gros bugs d'ombres qui partent dans tous les sens.

Si à la limite, vous pouvez me dire comment régler ce soucis sur Directx 9 je suis preneur

Bon après, c'est sûr c'est un peu moins joli... mais bon, c'est toujours mieux que des textures immondes
Essayez le réglage par défaut plutôt que de changer les options une à une. Chez moi ca a résolu la majorité des soucis.
Dans les paramètres qualité choisir une qualité par défaut. (pas utilisateur) : j'ai mis très haut.
Dans les paramètres affichage choisir DX9 ou Dx11 : j'ai pris dx11.

Au redémarrage j'ai bien le client Archage Dx11 qui s'ouvre (titre de la fenêtre).
J'ai gagné plein de FPS (30 fps en moyenne contre 23 avant).
Les bugs de textures sont parfois là mais a mon avis c'est pas un soucis de chargement, plus un soucis qu'il manque des textures HD car c'est toujours aux même endroits. (avant c'était aléatoire).

Je pense que la gestion des options est fortement buggée... par exemple je me suis retrouvé plusieurs avec le dx9 revenu tout seul par défaut entre 2 démarrages....





Bon alors diverses constatations:

-Les options changent d'elles même d'une connexion a l'autre...ou sont mal sauvegardées. Par exemple ma sélection dx11 se trouvait remplacée par dx9 sans raison. Donc leur menu d'option est archi buggé. (ce qui explique sans doute qu'on arrive a rien régler de façon permanente)

-mon problème de textures qui se floutent en dx11 est réapparu après 1 heure de jeu et de façon permanente: impossible de revenir a des textures nettes même après redémarrage.

- en passant en dx9 + option très haut les textures c'est bon mais: j'avais n'importe quoi au niveau des ombres (ombre flottante, surdimensionnées, clignotante etc.... imbuvable)

- j'ai donc finalement mis mes options en dx9 , enlevé le HDR, enlevé le flou profondeur de champ et l'l'antialiasing et tout le reste sur "très haut" puis redémarré. Et la enfin le jeu est beau. (j'ai un écran samsung avec un effet gaming qui me permet de me passer de HDR : même rendu).

Par contre toujours ce problème d'ombres totalement corrompues qui fini par survenir de temps à autre (surface sombre 10 fois plus grandes que l'ombre, ombre très longues et non appropriées etc...).

Ma solution quand cela arrive : baisser l'ongle shader + ombre sur Bas dans les options et confirmer puis refaire la manip a l'envers shader + ombre sur très haut et hop tout rentre dans l'ordre : je soupçonne que leur calcul des shader est pourri ou se dégrade dans le temps puisqu'une réinitialisation remet les choses en ordre. (ca prend 20 à 30s de calcul a chaque fois quand même donc éviter en combat)


Bon sur ce ce jeu est hyper buggué et j'ai envoyé un ticket salé au support archage pour leur signifier que prétexter que ces soucis n'arrivent pas a tout le monde (alors qu'ils arrivent quand même a beaucoup-) pour justifier une non correction ( j'ai lu ce genre de réponse de la part du manager communauté sur un forum) n'était pas acceptable et que je suis abonné pour jouer et pas payé pour déboguer leur programme et faire le boulot de leurs dev.

Si ce jeu reste dans l'état sans correction je n'irai pas plus loin que le 1er mois... quand sur 3h de jeu on en passe 2 à régler des options pour avoir un truc qui tient la route 30 min c'est inacceptable.




J'ai une GTX 770 et je n'ai aucun problèmes...

J'aimerais bien en faite de n'avoir aucun problèmes mais c'est loin d'être le cas sur ce jeu.

- Textures qui mettent un temps à s'afficher.
- Certaine textures dégueulasse ici et là.
- Crash du pc quand je me tp.
- Crash du pc quand une zone se charge.
- Lors des crash, j'ai soit un écran rouge, bleu, rose...
- Lors des crash, j'ai une image comme un écran de télé qui n'a pas sa chaîne (sauf que c'est en couleur).
- Ecran noir et obliger de redémarrer le pc.
- Lors des crash, tous mes paramètres sont remis par défaut.

Alors oui, je pense et crois que le jeu sur ce créneau est archi bug et que je n'irais pas plus loin que le mois gratuit, je n'ai déjà pas pu profiter pleinement de mon pré-lancement à cause de ces crash et des soucis de serveurs à n'en plus finir (Eanna).

Citation :
Publié par Bibi Fresh
C'est marrant durant la beta j'avais aucun de ses problèmes, maintenant oui
Pareil, lors de la beta, je n'avais aucun de tout ces problèmes.

Dernière modification par Ryldaar ; 16/09/2014 à 12h02.
@Alindiras : On a exactement les mêmes problèmes.

C'est clair que c'est vraiment inacceptable. Plusieurs fois j'ai voulu joué avec mon copain et on fini toujours par perdre un temps fou sur les réglages pour trouver une solution.

Le cache a fonctionné une fois, puis au bout de 10 minutes, les textures sont redevenues dégueulasse. On a revidé le cache, et là..." Ah bah tiens, le jeu n'a plus envie de résoudre le problème comme ça"...

Bref. J'ai l'impression qu'à part attendre un patch correctif de ce genre de problème on peut se la.... et bien profond !

Je suis vraiment tombé amoureux du jeu mais du coup, je suis obligé d'y jouer seul... Et ça me gonfle.
Répondre

Connectés sur ce fil

 
1 connecté (0 membre et 1 invité) Afficher la liste détaillée des connectés