MC - Technique et support

Permissions : pitié de l'aide

Répondre
Partager Rechercher
Bonsoir,


Je suis assez désespéré ! J'ai absolument rien compris quant à la configuration de Permissions (enfin je crois ? Sinon ça marcherais !). Alors, j'ai le bon fichier, que j'ai installé dans monserveur//plugings.


J'ai avec, le petit dossier avec le fameux RENAME-ME.yml. Avec dedans :

Code:
# System is no longer used, but may become used in the future
# Copies is for multiple-world support
#   Put the name of the world you wish for it to be a clone of, otherwise leave it empty.
#   If this file is for your default world (the one in server.properties) then you must
#   leave copies blank.
#  Example: copies: Derp    -  This will clone the permissions of the world Derp
#
# Make sure to rename this file to the name of the world that is in sever.properties under
# level-name.  So if it is level-name: world  then this should be world.yml and in the 
# plugins/Permissions directory (ie. plugins/Permissions/world.yml)
#
# NOTE: Do not use tabs while editing this document.  Use only spaces.  A good way to avoid
# doing this is to use Notepad++ and replace the tab with 4 spaces.
plugin:
    permissions:
        system: default
        copies: 

##        
# AntiBuild is included with this.  To disable a group from being able to build then
# set the build: flag to false (build: false).  If you want a group to be able to build
# then set it to true. 
##
# Groups can contain inheritance.
#   To make a group inherit the permissions from another
#   group simply place the groups name in the "inheritance:" like so:
#
#   Example:
#       inheritance:
#           - Default
##
#   All permissions including the asterisks must be placed in single quotes.
#   like so:
#
#       - 'foo.bar'
#
#   Otherwise errors will happen!
##
#   Globalized Permission settings:
#
#       If a permission contains periods (.) you can denote a globalized parameter:
#
#           - 'foo.*'
#
#       This will allow you to use all general commands.
#
##
#   Single Asterisk denotes all commands:
#
#       - '*'
#   If you give a group this permissions, do not have the group inherit any permissions
#   from other groups.  Any users assigned to this group should NOT be given any additional
#   permissions either.
##
#   To exempt a node use the - prefix like so:
#       - '-foo.bar'
##
#   prefix: and suffix: do not do anything on their own.  You need another outside plugin
#   such as iChat or HeroChat in order for these to do anything.
groups:
    Default:
        default: true
        info:
            prefix: ''
            suffix: ''
            build: false
        inheritance:
        permissions:
            - 'foo.bar'
    Moderator:
        default: false
        info:
            prefix: ''
            suffix: ''
            build: true
        inheritance:
            - Default
        permissions:
            - 'bar.foo'
    Admins:
        default: false
        info:
            prefix: ''
            suffix: ''
            build: true
        inheritance:
        permissions:
            - '*'

##
# Users denote which users are included in which group.
# TheNo1Yeti is in the Admin group
# Herpina is a member of the Moderator group but also has access
# to the herp.derp permissions
# Derpina is a member of the admin group but does not have access
# to the derp.derp permission node
# Users can also have a prefix and suffix as seen with Herpina
##
users:
    TheNo1Yeti:
        group: Admins
        permissions:
    Herpina:
        group: Moderator
        info:
            prefix: 'Moo'
            suffix: 'Cow'
        permissions:
            - 'herp.derp'
    Derpina:
        group: Admins
        permissions:
            - '-derp.derp'

Alors voilà, j'ai essayé de configurer le machin mais c'est une véritable horreur. J'ai configuré mon groupe Admin, comme ceci :

Code:
Admins:
        default: false
        info:
            prefix: ''
            suffix: ''
            build: true
        inheritance:
        permissions:
            - '*'
Et dans Users, je me suis ajouté comme ceci :

Code:
Cryt:
        group: Admins
        info:
            prefix: '[Admin]'
            suffix: ''
        permissions:
            - '*'
Alors logiquement, je devrais avoir les droits d'admin quand je me connecte n'es-ce pas ? Et bien je n'ai RIEN. Même pas le groupe par défaut avec lequel on ne peut pas construire ! Je peut construire, mais je suis pas admin J'ai essayé de mettre le groupe admin par défaut rien n'y fait !
Cela veux donc bien dire que le .yml n'est pas chargé ? Alors je comprends pas où j'ai fais l'erreur, je suis sérieusement pommé. Je vais dans mon server.proprieties :

Code:
level-name=Heavenly Island
Dans mon dossier de serveur, j'ai un dossier qui contient toutes les maps et compagnie du nom de Heavenly Island. Je file dans mon dossier plugings//permissions//Heavenly Island.yml. Je vérifie bien 15 fois que j'ai mit correctement le nom de mon serveur et rien à faire !


Un résumé pour ceux qui auront la flemme de lire (c'est tout à fait légitime) :

- J'ai paramétré permissions correctement (du moins je crois).
- J'ai renommer le RENAME-ME.yml avec le nom de mon serveur -> Heavenly Island.yml
- Rien ne marche, j'ai l'impression que permissions ne se charge pas.


J'implore votre aide J'ai regardé des tutos vidéos, écrits, mais à chaque fois c'est pas les mêmes lignes, pas la même version... Je suis presque sur que c'est un truc vraiment con mais je préfère 50 fois me prendre des coups de bâtons que resté coincé face à cette "kfea!?!!² ! Pitié
Je ne maitrise pas du tout mais déjà est ce que lors du démarrage du serveur tu as bien les messages comme quoi Permission est bien initialisé et chargé?
Si ce n'est pas le cas tu as peut être dans la console un message d'erreur (genre erreur de parsing du yml ou autre).

Ensuite j'ai essayé Permission hier pour la premiere fois mais d'après ce que j'ai compris si tu donnes des droits à un groupe (ta ligne Permission: -'*') tu ne devrais pas avoir besoins de le refaire dans la config des users, tu peux en ajouter ou en retirer j'imagine mais pas remettre les mêmes (tu affectes le user à un groupe il recupere donc les droits de ce groupe). Ca doit surement pas être la source de ton problème (si Permissions est bien codé) mais c'est précisément là l'intérêt de pouvoir gérer des groupes.
1) Attention aux espaces dans la configuration (là je pense que c'est à cause de Jol mais tes lignes sont décalées)

2)As-tu redémarrer ton serveur pour prendre en compte les modifications apportées au fichier de config ? (Je crois qu'il y a aussi la commande /permissions -reload all en jeu qui fonctionne, peut être qu'il faut rajouter le plugin PermissionsPlus pour avoir cette commande je ne sais plus)

3)Es-ce qu'il y a dans tes logs du serveur, des messages d'erreurs du type [Grave] [Sévère],etc ? Moi j'avais une incompatibilité entre Permissions et WorldGuard qui me faisais planter mes plugins.

4) Si ça ne fonctionne toujours pas, reprend ta config depuis 0:
-Tu renommes ton fichier RENAME-ME.yml avec le nom de ton monde (peut être es-ce qu'il n'accepte pas l'espace entre "Heavenly" et "Island" ?)
-Tu t'ajoutes toi et toi seulement en admin dans la partie "users" et tu ne touches pas à la partie "groups", aide toi des users déjà présent, voir même, remplace le nom d'un utilisateur par ton nom à toi.
-Fais bien attention aux espaces ! Je crois que si tu met des TABs, ça ne fonctionnera plus.
-Tu recharges la configuration en redémarrant le serveur ou par la commande en jeu.
-Tu te connectes et tu regardes si tu es admin.

Bonne chance !
Citation :
Publié par silverdro

4) Si ça ne fonctionne toujours pas, reprend ta config depuis 0:
-Tu renommes ton fichier RENAME-ME.yml avec le nom de ton monde (peut être es-ce qu'il n'accepte pas l'espace entre "Heavenly" et "Island" ?)
-Tu t'ajoutes toi et toi seulement en admin dans la partie "users" et tu ne touches pas à la partie "groups", aide toi des users déjà présent, voir même, remplace le nom d'un utilisateur par ton nom à toi.
-Fais bien attention aux espaces ! Je crois que si tu met des TABs, ça ne fonctionnera plus.
-Tu recharges la configuration en redémarrant le serveur ou par la commande en jeu.
-Tu te connectes et tu regardes si tu es admin.

Bonne chance !
C'est exactement ce que j'ai fais, et quand j'essaye de créer un shop par exemple il me met :

[Permissions] : You Can't make shops !

Donc apparemment Permissions fonctionne, mais il ne prend pas en compte le fichier de config ?

Citation :
Publié par kheld
Je ne maitrise pas du tout mais déjà est ce que lors du démarrage du serveur tu as bien les messages comme quoi Permission est bien initialisé et chargé?
Bah du coup vu qu'il m'interdit des trucs c'est qu'il doit marché, le problème c'est me mettre en admin quoi =(

Serveur log :

Citation :
13 12:51:49 [INFO] Fake Permissions version 2.6 is enabled!
C'est normal le mot Fake ? '_'
Je l'ai aussi le "fake permissions" et bien que je ne sache pas à quoi cela correspond exactement, je ne pense pas qu'il y a lieu de s'inquiéter.

Ce que je peux te conseiller de faire dans un premier temps:
Dans la partie "users", tu t'ajoutes toi et en dessous tu met "group: Admins" et rien d'autre (pas de suffixe, ni de permissions vu que tu es dans le group Admins).

Redémarre ton serveur, et essayes.

EDIT: ça peut paraitre bète mais, c'est la dernière version de Permissions avec la dernière version de Bukkit ?

Au cas où: peut être il y a une histoire d'incompatibilité, vire tous tes plugins et ne laisse que permissions, et essaye voir si tu es admins ?
Citation :
Publié par silverdro
Je l'ai aussi le "fake permissions" et bien que je ne sache pas à quoi cela correspond exactement, je ne pense pas qu'il y a lieu de s'inquiéter.

Ce que je peux te conseiller de faire dans un premier temps:
Dans la partie "users", tu t'ajoutes toi et en dessous tu met "group: Admins" et rien d'autre (pas de suffixe, ni de permissions vu que tu es dans le group Admins).

Redémarre ton serveur, et essayes.
Code:
users:
    Cryt:
        group: Admins
        permissions:
J'ai ça. Rien ne marche... Je suis désespéré.

Citation :
Publié par silverdro
EDIT: ça peut paraitre bète mais, c'est la dernière version de Permissions avec la dernière version de Bukkit ?

Au cas où: peut être il y a une histoire d'incompatibilité, vire tous tes plugins et ne laisse que permissions, et essaye voir si tu es admins ?
J'ai la version 2.6 de permissions et la 670 de bukkit. Oui je vais essayer ça !


[2min plus tard]


Je t'aimeuuuuuuuuuuh' ! Le problème venais de EssentialGroupManager / Brige ! Enfin je suppose ! Je les ai enlevé et tout marche impec ! Ahh je suis content ! Je savais que c'était un truc tout con ! Miles merci Silverdro ! Et à toi aussi Kheld !
Répondre

Connectés sur ce fil

 
1 connecté (0 membre et 1 invité) Afficher la liste détaillée des connectés