MC - Technique et support

[Résolu]Bukkit Problème plugin serveur local

Répondre
Partager Rechercher
Bonsoir,

Je cherche désespérément une solution à mon problème : le plugin Permission (et/ou les autres) ne veut pas fonctionner.

J'ai télécharger la version 2.7.1 de Permission ainsi que Bukkit 733
J'ai glisser le .jar dans "plugins", lancer le serveur puis stopper pour créer le .ylm
Code:
2011-04-28 18:10:28 [INFO] Starting minecraft server version Beta 1.5_02
2011-04-28 18:10:28 [INFO] Loading properties
2011-04-28 18:10:28 [INFO] Starting Minecraft server on *:25565
2011-04-28 18:10:28 [WARNING] **** SERVER IS RUNNING IN OFFLINE/INSECURE MODE!
2011-04-28 18:10:28 [WARNING] The server will make no attempt to authenticate usernames. Beware.
2011-04-28 18:10:28 [WARNING] While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
2011-04-28 18:10:28 [WARNING] To change this, set "online-mode" to "true" in the server.settings file.
2011-04-28 18:10:28 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-700-gf3ae4c3-b733jnks (MC: 1.5_02)
2011-04-28 18:10:28 [INFO] Preparing level "world"
2011-04-28 18:10:28 [INFO] Preparing start region
2011-04-28 18:10:29 [INFO] [Permissions] (Phoenix) was Initialized.
2011-04-28 18:10:29 [INFO] [Permissions] version [2.7.2] (Phoenix)  loaded
2011-04-28 18:10:29 [INFO] Done (0,088s)! For help, type "help" or "?"
2011-04-28 18:10:48 [INFO] Stopping the server..
2011-04-28 18:10:48 [INFO] CONSOLE: Stopping the server..
2011-04-28 18:10:48 [INFO] Stopping server
2011-04-28 18:10:48 [INFO] [Permissions] (Phoenix) saved all data.
2011-04-28 18:10:48 [INFO] [Permissions] (Phoenix) disabled successfully.
2011-04-28 18:10:48 [INFO] Saving chunks
2011-04-28 18:10:48 [INFO] Stopping server
2011-04-28 18:10:48 [INFO] Saving chunks
J'ai éditer le .ylm créer par permission (soit "Permissionsworld.yml") dans le dossier plugins comme ceci :

Code:
plugin:
    permissions:
        system: default
        copies: 

groups:
    Visiteur:
        default: true
        info:
            prefix: '&2'
            suffix: '&2'
            build: true
        inheritance:
        permissions:
            - 'lwc.protect'
    Moderateur:
        default: false
        info:
            prefix: '&1'
            suffix: '&1'
            build: true
        inheritance:
            - Visiteur
        permissions:
            - 'lwc.mod'
    Admin:
        default: false
        info:
            prefix: '&4'
            suffix: '&4'
            build: true
        inheritance:
        permissions:
            - '*'

users:
    NadakoMei:
        group: Admin
        permissions:
            - '*'
Puis j'ai rajouter les plugins MultiVerse v1.6.3 et LWC v2.31 puis j'ai relancer le serveur :

Code:
2011-04-28 18:17:13 [INFO] Starting minecraft server version Beta 1.5_02
2011-04-28 18:17:13 [INFO] Loading properties
2011-04-28 18:17:13 [INFO] Starting Minecraft server on *:25565
2011-04-28 18:17:13 [WARNING] **** SERVER IS RUNNING IN OFFLINE/INSECURE MODE!
2011-04-28 18:17:13 [WARNING] The server will make no attempt to authenticate usernames. Beware.
2011-04-28 18:17:13 [WARNING] While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
2011-04-28 18:17:13 [WARNING] To change this, set "online-mode" to "true" in the server.settings file.
2011-04-28 18:17:13 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-700-gf3ae4c3-b733jnks (MC: 1.5_02)
2011-04-28 18:17:13 [INFO] Preparing level "world"
2011-04-28 18:17:13 [INFO] Preparing start region
2011-04-28 18:17:14 [INFO] LWC    Loading shared objects
2011-04-28 18:17:14 [INFO] LWC    Native library: plugins/LWC/lib/native/Linux/i386/libsqlitejdbc.so
2011-04-28 18:17:14 [INFO] [Permissions] (Phoenix) was Initialized.
2011-04-28 18:17:14 [INFO] [MultiVerse] Permissions Found
2011-04-28 18:17:14 [INFO] [MultiVerse] - Version 1.6.3 Enabled
2011-04-28 18:17:14 [INFO] [MultiVerse] Loading World & Settings - 'world' - NORMAL
2011-04-28 18:17:14 [INFO] [MultiVerse] 1 - World(s) loaded.
2011-04-28 18:17:14 [INFO] [MultiVerse] Loading Portals
2011-04-28 18:17:14 [INFO] [MultiVerse] 0 - Portal(s) loaded.
2011-04-28 18:17:14 [INFO] LWC    Loaded 116 locale strings (0 overrides)
2011-04-28 18:17:15 [INFO] Updater    Need to download 2 file(s)
2011-04-28 18:17:15 [INFO] Updater     - Downloading file: sqlite.jar
2011-04-28 18:17:18 [INFO] Updater      + Download complete
2011-04-28 18:17:18 [INFO] Updater     - Downloading file: libsqlitejdbc.so
2011-04-28 18:17:20 [INFO] Updater      + Download complete
2011-04-28 18:17:20 [INFO] LWC    Using Nijikokun's permissions plugin for permissions
2011-04-28 18:17:20 [INFO] [Permissions] version [2.7.2] (Phoenix)  loaded
2011-04-28 18:17:20 [INFO] [MultiVerse] Found Permissions, enabling commands.
2011-04-28 18:17:20 [INFO] LWC    Loading SQLite
2011-04-28 18:17:20 [INFO] SQLite    Using: Native
2011-04-28 18:17:20 [INFO] LWC    At version: v2,31
2011-04-28 18:17:20 [INFO] Done (0,679s)! For help, type "help" or "?"
Cepandant, rien à faire, impossible de créer un portail pour le nether (/mvcreate nether) ou de bloquer un coffre (/lwc -c private), celà m'affiche "You do not have the rights to access this command"

Pourtant, je me suis bien mis Admin avec toutes les commandes et mes plugins sont compatibles

Voilà, si quelqu'un peut m'aider

Edit du 05/04/11 : Mon problème est résolu grâce à l'update Bukkit 818 et à permission 3.X
Code:
2011-04-28 18:10:28 [WARNING] To change this, set "online-mode" to "true" in the server.settings file.
Quand tu ouvres server.proprieties avec notpad ou autre, online-mode est sur true ou false ?
Citation :
Publié par Cryt
Code:
2011-04-28 18:10:28 [WARNING] To change this, set "online-mode" to "true" in the server.settings file.
Quand tu ouvres server.proprieties avec notpad ou autre, online-mode est sur true ou false ?
Il est sur false, je vient d'essayer avec true et ça ne fonctionne pas non plus
Citation :
Publié par Cryt
Si tu le met sur false tu pourra pas jouer en ligne avec ton serveur, donc met sur true ^^

Ensuite si ça peut t'aider j'avais fait deux topics où j'avais des problèmes avec permissions :

https://forums.jeuxonline.info/showthread.php?t=1127317

https://forums.jeuxonline.info/showthread.php?t=1126898
Le true ou false de online-mode sert à vérifier ou non si les pseudos existe sur minecraft.net (et donc éviter les joueurs avec un client cracké) je pense non ?
Dans le doute, je met sur true.

J'ai regardé tes sujets avec Permissions avant de poster mon sujet, merci quand même
tu n'as pas besoin de rajouter la dernière ligne

Code:
 - '*'
ceci devrait suffire.
Code:
users:
    NadakoMei:
        group: Admin
        permissions:
(à noter qu'il faut impérativement mettre des espaces et non des TAB pour l'indentation)
Honnêtement je ne vois pas, a part une erreur avec un Caractère ton fichier à l'air bon.
Si tu reprends le fichier de base ça marche ? sans modifier les groupes ?
Dans le cas où ton serveur est sous linux ET ton pc perso sous windows :

Il y a peut-être un problème de conversion Windows/Linux dans le format du fichier.

Sous windows et linux les caractères spéciaux qui indiquent les sauts de lignes ne sont pas tout à fait les mêmes:

\n sous Windows
\r\n sous Linux

Essaye de voir dans les réglages de ton client FTP si il n'y a pas une petite blague qui fait de la conversion de fichiers ou je ne sais quoi, si tu n'a pas déjà tenté, essaye d'ouvrir ton fichier directement sur ton serveur avec VI pour voir si les lignes sont bien séparées comme il se doit ?

C'est juste une idée pour voir..
Citation :
Publié par iAlree
Si tu reprends le fichier de base ça marche ? sans modifier les groupes ?
Non ça ne fonctionne pas :/
Même mes amis qui me rejoignent sur le serveur n'ont pas accès aux commandes (ils ont le même message)

Citation :
Publié par Black Lemming
...
Mon serveur est en local sur mon pc qui est sous linux, il faut que je fasse une conversion ?

Edit du 04/05/11 : La version 3.X de permission à résolu mon problème
Répondre

Connectés sur ce fil

 
1 connecté (0 membre et 1 invité) Afficher la liste détaillée des connectés