Bienvenue sur JeuxOnLine - MMO, MMORPG et MOBA !
Connectés : 1081 (sites) | 1928 (forums)
Les sites de JeuxOnLine...
 
Forums MMO, MMORPG et MOBA
Forums MMO, MMORPG et MOBA
   
   
Précédent   Les forums MMO, MMORPG, MOBA > Second Life > SL - Forum technique > problème avec textures RSS
Tous les forums de JeuxOnLine
   
Réponse
 
Partager Outils de la discussion
:.Gourmandise.:
Seigneur
 
Avatar de :.Gourmandise.:
 

problème avec textures

je ne comprends pas ce qui se passe avec mes sculpts quand je les texture....je vous poste 2 photos. La première c'est ce que je veux voir ...la deuxième c'est ce que je vois parfois et je ne récupère le bon affichage des textures qu'après avoir fait un clique sur mon objet comme si je voulais l'éditer. Si j'éloigne ma caméra la texture disparaît et laisse place au gris terne comme celui des maillons supérieurs que l'on voit photo deux. A quoi est du ce problème ? Avez vous ce soucis ? je précise que j'utilise Firestorm, mes amis ont également un affichage défaillant quand il regardent ma chaîne. Merci pour votre aide .
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom : Snapshot_002.jpg
Affichages : 12
Taille : 255,4 Ko
ID : 177514   Cliquez sur l'image pour la voir en taille réelle

Nom : Snapshot_001.jpg
Affichages : 13
Taille : 221,3 Ko
ID : 177515  
:.Gourmandise.: est déconnecté Vieux 10/11/2012, 21h09
Afficher le profil de :.Gourmandise.:
Compte #361860
Invité
 
Preferences → Graphics → Hardware Options (button) → Enable Vertex Buffer Objects
Vieux 11/11/2012, 01h34
Afficher le profil de Compte #361860
:.Gourmandise.:
Seigneur
 
Avatar de :.Gourmandise.:
 
Merci beaucoup pour ta réponse ilostmyimagination, j'ai déjà cette option activée dans mes préférences graphiques, donc ce n'est pas de là que vient mon problème. Mais si tu as d'autres conseils je suis preneuse.
Bonne journée
:.Gourmandise.: est déconnecté Vieux 11/11/2012, 09h46
Afficher le profil de :.Gourmandise.:
Compte #361860
Invité
 
Il y aura probablement un spécialiste qui passera ici peut être que cela vient de la texture de ton sculpt prim.

Q. Quel est le niveau de détail maximal d’un sculpted prim ?
L’actuel implémentation des Texture Sculpted fait varier le résultat en fonction du niveau de détail ou LOD (Level Of Details) affiché dans le client. Les prims proches de la camera auront une précision de 32*32 mais passent à 16x16 des que la prim s’éloigne de la caméra.
Q. Quelle doit être la taille de ma texture?
La taille recommandée est de 64x64 pixels. Davantage de données serait inutile et une résolution plus basse peut aboutir à un mauvais échantillonnage en cas de changement de niveau de Détail(LOD).
Vieux 11/11/2012, 14h54
Afficher le profil de Compte #361860
JOL Kyle Brynner
Dieu souverain
 
Avatar de Kyle Brynner
 
Il est conseillé, en effet de ne pas dépasser la taille de 64 x64 pixels concernant la texture qui donne la forme au sculpty (la fameuse UVmap).

Pour ce qui est de la texture appliquée à un sculpty, on peut aller jusqu'à la résolution maximum autorisée dans SL (1024x1024).

Mais le problème avec les niveaux de détails inférieurs affichés par le viewer lorsqu'on s'éloigne, c'est que les normales semblent recalculées si bien que parfois la texture ne s'affiche pas correctement.

Je me rappelle d'un vieux fil de discussion dans lequel j'étais intervenu et où un problème similaire avait été abordé. Je l'ai retrouvé (Ah ouais… janvier 2009, tout de même ) : http://forums.jeuxonline.info/showthread.php?t=962779

Je ne sais pas si les propositions faites ont été des solutions, mais c'est effectivement une des nombreuses limitations des sculpties par rapport aux meshes.
Kyle Brynner est déconnecté Vieux 11/11/2012, 19h10
Afficher le profil de Kyle Brynner
:.Gourmandise.:
Seigneur
 
Avatar de :.Gourmandise.:
 
Merci pour vos réponses, je ne sais pas trop quoi faire ....je vais regarder du coté des meshs......
:.Gourmandise.: est déconnecté Vieux 11/11/2012, 20h08
Afficher le profil de :.Gourmandise.:
Marianne Qunhua
Immortelle
 
Avatar de Marianne Qunhua
 
bonjour,

Je ne sais pas si cela peut vous aider, mais il y a un moment, on devait mettre le " RenderVolumeLODFactor " à 4, pour voir correctement les sculpties de loin.

Par contre pour voir en zoomant de près, faut ajuster le " rendermaxNodeSize " à 8192.

Dans Firestorm on peut changer les valeurs directement, par le bouton "réglages rapides".
__________________
Marianne Qunhua est déconnecté Vieux 12/11/2012, 16h04
Afficher le profil de Marianne Qunhua
:.Gourmandise.:
Seigneur
 
Avatar de :.Gourmandise.:
 
Merci Marianne, j'ai bien mon LOd à 4. par contre pour le deuxième paramètre, je me demande si c'est ce qui correspond aux particules car c'est le seul qui peut se mettre à 8192. Si v'est bien ça, j'ai fait un essai et malheureusement, çà ne change pas mon soucis. .
Je vais briser mes chaînes .....
:.Gourmandise.: est déconnecté Vieux 12/11/2012, 17h47
Afficher le profil de :.Gourmandise.:
jefflg
Comte / Comtesse
 
Avatar de jefflg
 
| Modéré par Serenna : Oui (Plus d'infos ~> ModoAide ) |

Dernière modification par Serenna ; 13/11/2012 à 13h27.
jefflg est déconnecté Vieux 12/11/2012, 18h14
Afficher le profil de jefflg
Réponse
Forums jeux vidéo MMORPG   Les forums JeuxOnLine > Second Life > SL - Forum technique > problème avec textures
   

Outils de la discussion

Thème visuel : Fuseau horaire GMT +2. Il est actuellement 18h12.