VG - Problèmes techniques et modifications d'interface

Anti-Aliasing dans Vanguard : Ca marche !

Répondre
Partager Rechercher
Depuis le début, j'ai toujours voulu activer l'AA dans Vanguard sans succès, meme en le forçant dans les pilotes nvidia.

Depuis décembre j'ai une 8800GT et j'ai mis à jour mes pilotes. Hors, je ne sais pas si c'est lié au changement de carte (j'avais une 7900GT) ou à la nouvelle version des pilotes, mais l'AA fonctionne parfaitement maintenant si on le force dans le panneau d'affichage.

Mes pilotes : 169.21 / Carte 8800GT / Vista 64

Aller dans le panneau d'affichage nvidia, onglet paramètre 3D / Gerer les paramètres 3D

Dans le Menu déroulant, activer :
- Anticrénelage mode : "Remplacer tout paramètre d'application"
- Anticrénelage réglage : x2, x4 etc... selon votre convenance

faire "appliquer" puis sortir

Maintenant l'AA fonctionne dans Vanguard (et dans tous les jeux par defaut).
Dans les "Settings", "Video" de Vanguard, décocher le HDR et le bloom sinon vous aurez un écran voilé.
Voilà. Ca marche !
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom : ScreenShot_00028.JPG
Taille : 1280x1024
Poids : 155,6 Ko
ID : 35715  
Citation :
Publié par Gaelynn
Depuis le début, j'ai toujours voulu activer l'AA dans Vanguard sans succès, meme en le forçant dans les pilotes nvidia.

Depuis décembre j'ai une 8800GT et j'ai mis à jour mes pilotes. Hors, je ne sais pas si c'est lié au changement de carte (j'avais une 7900GT) ou à la nouvelle version des pilotes, mais l'AA fonctionne parfaitement maintenant si on le force dans le panneau d'affichage.

Mes pilotes : 169.21 / Carte 8800GT / Vista 64

Aller dans le panneau d'affichage nvidia, onglet paramètre 3D / Gerer les paramètres 3D

Dans le Menu déroulant, activer :
- Anticrénelage mode : "Remplacer tout paramètre d'application"
- Anticrénelage réglage : x2, x4 etc... selon votre convenance

faire "appliquer" puis sortir

Maintenant l'AA fonctionne dans Vanguard (et dans tous les jeux par defaut).
Dans les "Settings", "Video" de Vanguard, décocher le HDR et le bloom sinon vous aurez un écran voilé.
Voilà. Ca marche !
Trop bon! J'avais effectivement pas retesté depuis longtemps, n'y croyant plus... Je regarderai ca ce soir!

Par contre, ce n'est pas dommage de devoir desactiver le HDR et bloom tout de meme?
Malheureusement, si l'HDR est coché les graphismes sont illisibles (en tout cas chez moi c'est le cas). Je ne crois pas que le bloom fonctionne mais je peux me tromper (perso j'aime pas).

Après entre l'AA et l'HDR, pour moi y a pas photo même si idéalement on devrait avoir les deux.
Citation :
Publié par Gaelynn
Après entre l'AA et l'HDR, pour moi y a pas photo
C'est sur...
Et ya pas moyen de forcer le HDR a partir des parametres NVidia de la meme maniere que l'AA? Soyons fou
effectivement ça marche !

(je viens de recevoir ma 8800 GT ^^)

A noter que plutôt que de forcer le paramètre global, il est possible de le forcer que pour Vanguard (onglet "paramètres de programme")
Ca fonctionnait déjà chez moi à l'époque (j'avais testé en avril dernier), mais provoquait des bugs avec les polices de caractères à l'écran (qui disparaissaient selon l'angle d'affichage). J'ai pas retesté depuis, ils ont corrigé ça?
Bon je vien d'essayer aussi!
Ba c'est sur que ca fait du bien aux yeux hein, ca ya pas a dire, mais ca fait pas trop trop du bien aux fps ^^
En AA 16x je suis a 20 fps a l'ecran de choix des persos et ca tourne a peux pres a 5-10 en jeu huhu ^^ (avec une 8800GT mais un 3500+)

Bon en AA 2x c'est carement mieux hein mais qd meme!
Aloha,

J'ai telecharge les derniers drivers pour ma 8800 sous vista 32-bit et en effet ca fonctionne.

Seul probleme, pour moi, avec ces nouveaux drivers, ni mon pc, ni Vanguard ne m'autorisent a utiliser la resolution native de mon ecran: 1360x768 (televiseur HD Ready 32'). Ce qui fait que j'ai une resolution pas du tout adaptee et qu'une partie de l'image (en largeur) depasse donc de l'ecran. Si vous avez une idee, sinon j'attendrai que ce soit implante en jeu sans devoir bidouiller.
Citation :
Publié par Hyunkiel
Bonjour / Bonsoir

Quelqu'un pourrait expliquer au noob que je suis en terme de vidéo etc etc etc. Ce qu'est l'anti-aliasing et votre HDR ? Merci bien !

Amicalement Hyu.
L'anti-aliasing ou anti-crénelage est un traitement qui permet, comme son nom l'indique ^^, de lisser les bords des objets afin de reduire l'impression d'escalier qui apparait sur les diagonales.
C'est en generale un des effets prioritaires puisqu'il permet de 'depixeliser' les polygones. D'autant plus que c'est, je crois bien un des premier effets qui a ete ajouté en hardware aux cartes graphique tellement il est commun.
Il est aujourd'hui possible d'avoir des anti-aliasing a plusieurs passes (2x, 4x, 8x, 16x...) qui permettent un lissage encore plus precis mais qui bouffent aussi beaucoup plus de ressources...

L'HDR ou High Dynamic Range c'est un peu plus obscure pour moi. D'apres ce que j'ai compris ca permet notament d'associer a chaque pixel, en plus de leur valeur de couleur, des valeurs de luminescence ou des trucs comme ca et ca permet donc d'avoir des couleurs et des lumieres vachement plus realistes.
Bon pour etre franc, dans vanguard j'ai jamais vu la difference avec et sans
Citation :
Publié par Kiiv
L'HDR ou High Dynamic Range c'est un peu plus obscure pour moi. D'apres ce que j'ai compris ca permet notament d'associer a chaque pixel, en plus de leur valeur de couleur, des valeurs de luminescence ou des trucs comme ca et ca permet donc d'avoir des couleurs et des lumieres vachement plus realistes.
Bon pour etre franc, dans vanguard j'ai jamais vu la difference avec et sans
Dans la plupart des jeux, l'HDR permet de faire briller excessivement les armures et tout ce qui est en métal, et aussi tout ce qui est source de lumière. L'effet est en général bien trop artificiel pour ajouter au réalisme et à l'immersion.

Quant au bloom, cela ajoute une sorte de brouillard lumineux assez pénible, transformant n'importe quel guerrier viril en nymphe floue et vaporeuse à la David Hamilton... Là aussi cela nuit au réalisme.
En faite le problème n'a jamais été de ne pas pouvoir forcer l'application de l'AA mais bien que ça fonctionne parfaitement en jeu une fois l'AA forcé.

Il suffit de le forcer et de s'apercevoir qu'n jeu ça ne fonctionne pas très bien, car les noms par exemple s'efface lorsqu'on est en face d'un pnj, voir même son propre nom, et le nom ré-apparait une fois que la caméra est tournée d'une autre position.
oui, ça c'était le problème qu'il y avait avant, mais justement ce n'est plus le cas !
Je confirme à 100%, l'AA fonctionne parfaitement et les noms sont parfaitement lisibles en permanence.
Citation :
Publié par Nyssa
je viens de tester et ça fait toujours la même chose
Tout comme Gaelynn, ca marche nikel aussi. Je n'ai effectivement plus ce probleme de noms qui disparaissent (en fait ce sont les fenetre qui laissent un 'masque' quand tu les ouvres).

Soit c'est lié a la carte graphique, soit au drivers...
Je tiens avant tout à remercier Galeynn, qui m'a incité à faire des test sur mon peu de temps de jeu aujourd'hui au lieu de m'amuser

Le résultat est que, avec une bonne carte ATI (HD 3870 512 Mo, derniers pilotes installés), forcer l'AA ne semble pas fonctionner, comme on peut essayer de faire la comparaison sur les deux captures qui suivent (je ne trouve pas la qualité des captures très bonne par contre )

Je ne sais pas si c'est le cas pour toutes les cartes ATI, et je ne voudrais pas qu'on en tire des conclusions hâtives. Cette carte me donne une entière satisfaction sur tous les jeux Vanguard compris, loin des mauvaises critiques qui sont faites à la marque actuellement. Et vu que l'anti-aliasing fonctionne ailleurs, c'est sans doute plus le moteur du jeu à mettre en cause, qui de toutes façons aura beaucoup de mal à devenir compétitif malgré les efforts apparents à mon avis.

En même temps, tous ces tests m'ont créées des problèmes sur le rendu des ombres avec une complexité à 100% (quelque soit le réglage remis en place ensuite). Je verrais si le problème persiste au redémarrage de l'ordinateur, mais c'est secondaire pour le moment.
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom : ActivationAA.JPG
Taille : 1440x900
Poids : 293,3 Ko
ID : 35952   Cliquez sur l'image pour la voir en taille réelle

Nom : Reglages VG.JPG
Taille : 1440x900
Poids : 294,3 Ko
ID : 35953  
Hmpf..encore une elfe anorexique ou comment ressembler a Paris Hilton version Haute-Elfe...

Chez moi j'ai essayé d'inclure le AA, bizarre cela n'a pas fonctionné, je retenterais l'expérience plus tard.

[EDIT1]

Ok, ça fonctionne c'est bien plus beau.
@Kerlo ^^ ouelcome back

D'après ce que j'ai pu lire, l'adaptative AA réglé en mode qualité dans les pilotes ATI fonctionnerai, du moins sur une 2900XT (mais comme la 3870 est basée sur le même chipset...)

Vu sur le forum technique de Vanguard posté par un joueur équippé d'une 2900xt :
Citation :
I am running adaptive AA set to quality and I am getting 28 (city) to 55 (countryside). Turning AA on didn't give me the hit I would have though and it looks crazy good. On the character select screen my armor looks fantastic.
* Sinon, l'Environemental Shader (dans Setting/Video de Vanguard) est buggé au delà de 80%, il faut s'assurer que son réglage est < 80%

* Si vous avez des problèmes visuels type arbres qui clignotent/disparaissent, cela vient à priori du "Hardware Occlusion" qu'il faut décocher.

* Pour les ombres, je ne pense pas que les régler à 100% apporte grand chose (de mon experience en tout cas) si ce n'est des fps en moins. Perso j'ai baissé significativement le slider (genre 50% ou moins) et je n'ai pas vu de difference justifiant son coût, mais ça depend peut être des endroits.

Par contre si quelqu'un a un tuyau pour pouvoir afficher la pluie sous vista je suis preneur.
Merci Gaelynn, c'est un retour temporaire, le temps de la réactivation, rien n'est moins sûr pour la suite
J'espère que de ton coté le jeu te donne encore toute satisfaction avec le temps.

J'avais essayé avec et sans l'Adaptive AA avec le même résultat, mais je referais une batterie de test, c'est assez lourd vu le nombre de réglages possibles mais on verra bien.

L'environnement Shader est réglé "au plus juste", c'est à dire avant l'apparition des bugs d'affichage (avec une marge, je suis donc à 75%), et ne me pose pas de soucis. De même pour les occlusions, Hardware ou Character pour être sûr de ne pas avoir de soucis.

Pour les ombres le soucis c'est que je n'ai plus de problèmes en dessous de 20%. A ce stade autant les enlever car les ombres de personnages ne sont plus que de gros halos circulaires sombres. Vu que je n'avais pas eu de soucis jusqu'à ce matin, je ne suis pas plus inquiet que ça pour le moment

Mais au moins j'ai de la pluie, sous XP

nb: je suis désolé si ce personnage est si stéréotypés, je trouve vraiment toujours aussi mauvais le rendu de certaines races (souvent humaines et assimilées) malgré le nombre de paramètres qui au final font très peu de différences
^^ J'ai repris depuis peu (enfin 1 mois en gros) et je suis très satisfait malgré les défauts du jeu. Je viens de rejoindre la guilde Fondation (qui comprend quelques anciens de Paragon entre autres) et l'ambiance est très bonne, si tu décides de rester n'hésite pas à me contacter (Tsubarukai)

Sinon un petit truc pour limiter les baisses de FPS dans certains cas, c'est de réduire le nombre max de lumières à 2 ou 3 dans les settings.
Eh bien je confirme les dires Kerloken, impossible (comme depuis la beta) de faire marcher l'AA sur une carte ATI Au mieux, on a le bug des noms invisibles mais sans l'effet de l'AA.

J'ai essayé moult-combinaisons (AAx2/x4/x6, AFx0/x2/x4/x8/x16, Catalyst AI off/standard/avancé, HDR off/on, Adaptive off/on/qualite/performance, etc etc...) toute l'après midi et rien

D'ailleurs en lisant le sujet d'où provient ta citation sur le joueur avec une 2900xt, on s'aperçoit que ça n'a jamais marché non-plus au final (effet placebo ?).
Ce qui ne m'étonne qu'a moitié car l'Adaptive AA n'a rien à voir avec le FSAA. Cela permet d'appliquer un filtre AA sur des objets très précis (les textures contenant de la transparence en-fait) comme des grillages ou autre petit trucs du genre, et c'est dépendant du niveau FSAA général.

Dommage car en voyant vos screens avec AA c'est vraiment superbe

Reste plus qu'a acheter une 8800gt pr remplacer ma vieille radeon x1900xt

Mais bon le jeu est déjà magnifique comme ça et je dois dire que je suis surpris par l'optimisation qu'il y a eu depuis Mars 2007. Le jeu est beaucoup plus fluide sans avoir besoin de toucher au ini, et de nombreuses options sont apparues IG permettant d'affiner les réglages. Il reste toujours ce problème de saccades à l'approche d'une ville/village mais bon.. Et apparemment, ils ont fortement réduit le LOD des objets, l'effet de pop sous les yeux est chiant mais on s'y habitue.

Par-contre les temps de chargement, ça n'a plus rien à voir. Je met environ 10/20sec entre le moment où j'appuie sur "Jouer" et l'entrée dans le monde effective alors qu'avant, ça avoisinait bien la minute.

Mais je pars en HS la ^^

Edit : eh ben c'est le retour de pas mal d'anciens on dirait
Citation :
Publié par Kaworu-kun
Reste plus qu'a acheter une 8800gt pr remplacer ma vieille radeon x1900xt
Je viens de revenir aussi suite à la réactivation de mon compte, et j'ai d'abord joué deux jours avec mon ancienne X1950XT, puis ai reçu ma 8800GT... franchement la différence est énorme !

Sur la X1950XT je trouvais ça plus ou moins joli et plus ou moins fluide, là c'est magnifique et extrêmement fluide !

Enfin je dis ça comme ça hein
Répondre

Connectés sur ce fil

 
1 connecté (0 membre et 1 invité) Afficher la liste détaillée des connectés