JeuxOnLineForumsPlusConnectés : 442 (sites) | 1251 (forums)Créer un compte
ArcheAge>ArcheAge - Forum technique
Optimisation
Répondre
Partager Rechercher
Avatar de -Nova-
-Nova-
Vicomte / Vicomtesse
 
Avatar de -Nova-
 

Problème texture Direct11 Nvidia

Salut, si j'ouvre ce topic, c'est pour parler des problèmes liés aux textures qui ont du mal à charger en jeu. Un problème lié aux cartes graphiques Nvidia plus ou moins récentes apparemment.

Il y a cette solution (à l'étape 2) : http://archeage-ressource.fr/config.php

Mais en ce qui me concerne, le problème persiste et je crois que je ne suis pas le seul.

Que ce soit avec DirectX 9 ou 11, les textures ne charges pas correctement et parfois ça donne ceci :



Si je pouvais transformer ce post en TUTO, je le ferais, mais pour le moment c'est compliqué

Je me dis qu'il doit y avoir un problème avec les étapes expliquées dans le lien citer plus haut, avec par exemple l'histoire du "lecture seul" coché/décoché.

D'ailleurs, pour l'étape 1, il vaut mieux utiliser PhysX avec le GPU pour ceux qui ont une bonne carte : http://www.nvidia.fr/object/nvidia-physx-faq-fr.html)


Ce que j'ai fait :

J'ai bien remplacé le "system.cfg" par le nouveau dans \Mes Documents\ArcheAge\

Après c'est là que je me suis peut-être planté, j'ai mis le contenu du nouveau dossier "bin32" (DLLs DirectX11) dans les originaux de la version beta et alpha. Mais il me semble que c'est bon, enfin bref..

En gros ça donne ceci : Glyph\Games\ArcheAge\Alpha\Bin32 et Glyph\Games\ArcheAge\Beta\Bin32.

Puis lecture seule du "system.cfg" décoché, lancement du jeu, changement de résolution (ça nous met d'office une basse résolution qu'il faut changer), j'ai quitté le jeu et fermer le luncher et enfin j'ai remis en "lecture seule".

Et donc, ça ne fonctionne pas.


 

Ici je mets l'étape 2 en question :


Optimisation 2 : Le vrai directX 11.

Lorsque vous installez pour la première fois ArcheAge, vous constaterez que le DirectX11 est une émulation du directX10. Voici comment optimiser votre jeu avec le vrai directX11 :

1. Installez les DLLs DirectX11 dans le dossier Glyph\Games\ArcheAge\Bin32.

2. Placez le fichier system.cfg dans le dossier \Mes Documents\ArcheAge\, puis retirez le mode lecture seule, redéfinissez votre résolution d'écran, sauvegardez et remettez la lecture seule.

3. Votre Jeu est désormais sous le vrai pilote DX11. Pour les Nvidia, vous pouvez également installer Nvidia Inspector, recherchez dans la barre le jeu ArcheAge, puis activer l'option "toggle fxaa on".




Si quelqu'un peut apporter quelques précisions pour essayer de résoudre ce problème, ce serait d'une grande aide merci.
Watchy
Dauphin / Dauphine
 
Les problèmes ne sont pas qu'avec des NVIDIA.

J'ai essayé le jeu avec ma GTX 460 et ma 7950 HD et j'ai le même problème :
- des textures qui mettent un temps fou à apparaitre et/ou restent en very low
- des personnages qui disparaissent de partout, du coup je vois même pas les symboles au dessus de leur tête
- à la connexion, et de temps en temps, j'ai carrément aucune animation de mon personnage : il glisse (les autres personnages risquent pas, ils n'apparaissent pas... lol)

Donc je pense que ça vient plus du processeur qui suit pas ou de la RAM.
J'ai 4 Go de RAM et un core2duo bas de gamme (je peux pas préciser je suis pas sur mon pc là)
En very low, ça attenue beaucoup le problème mais bon foutre du very low sur une 7950

La technique du Dirext11 marche pas non plus, il me dit qu'il y a un problème avec le fichier D3DCompiler_42 et la case DX11 reste tout le temps grisé alors que je suis sous Vista et à jour

Bref le jeu est quand même le plus buggé techniquement auquel j'ai joué depuis très longtemps.

Dernière modification par Watchy ; 27/08/2014 à 09h13.
Avatar de Memoris
Memoris
Alpha & Oméga
 
Avatar de Memoris
 
Citation :
Ce que j'ai fait :

J'ai bien remplacé le "system.cfg" par le nouveau dans \Mes Documents\ArcheAge\

Après c'est là que je me suis peut-être planté, j'ai mis le contenu du nouveau dossier "bin32" (DLLs DirectX11) dans les originaux de la version beta et alpha. Mais il me semble que c'est bon, enfin bref..

En gros ça donne ceci : Glyph\Games\ArcheAge\Alpha\Bin32 et Glyph\Games\ArcheAge\Beta\Bin32.

Puis lecture seule du "system.cfg" décoché, lancement du jeu, changement de résolution (ça nous met d'office une basse résolution qu'il faut changer), j'ai quitté le jeu et fermer le luncher et enfin j'ai remis en "lecture seule".

Et donc, ça ne fonctionne pas.


En ouvrant le fichier...



Citation :
-- [SYSTEM CONFIGURATION]
-- WARNING! THIS FILE IS GENERATED BY THE SYSTEM! EDITING IS NOT RECOMMENDED!

sys_spec_full = 4
sys_MaxFps = 60
r_driver = "DX11"
r_multithreaded = 1
r_windowx = -1
r_windowy = -1
r_width = 1920
r_height = 1080

r_fullscreen = 1
r_vsync = 0
r_multiGPU = 2
login_first_movie = 0
ucc_ver = 2
auto_disconnect_timer = 30

e_Tessellation = 1
r_TexturesStreamPoolSize = 1024
r_WaterTessellationHW = 1
r_TessellationMaxDistance = 60
r_TessellationTriangleSize = 8
r_ssao = 0
r_ssdo = 2
r_SSReflections = 2
r_Sharpening = 0.40
r_HDRBloomRatio = 0.20
e_GI = 1
e_GICache = 6
e_LodRatio = 40
e_MergedMeshesInstanceDist = 15.0
e_MergedMeshesViewDistRatio = 60
e_ParticlesForceSoftParticles = 1
e_ParticlesObjectCollisions = 2
En rouge ce qu'il faut changer je crois bien et non en jeu (sinon le jeu doit se remettre en Dx10 dès que tu le lance et qu'il n'est pas en lecture seule).
Avatar de -Nova-
-Nova-
Vicomte / Vicomtesse
 
Avatar de -Nova-
 
Merci pour vos réponses, je n'ai pas modifié la résolution dans le fichier, donc je vais faire ça merci.

Sinon, en fouillant un peu, j'ai vu que cette méthode ne fonctionner plus depuis l'une des mises à jour apparemment.

Je vais attendre la sortie et je verrais bien, un patch officiel se serait bien quand même.
Avatar de Alindiras
Alindiras [E.D.R]
Roi
 
Avatar de Alindiras
 
Citation :
Publié par Watchy
...

Donc je pense que ça vient plus du processeur qui suit pas ou de la RAM.
J'ai 4 Go de RAM et un core2duo bas de gamme (je peux pas préciser je suis pas sur mon pc là)
En very low, ça attenue beaucoup le problème mais bon foutre du very low sur une 7950 ....
Non rien a voir avec les performance du procs ou de la ram, j'ai un pc avec i7 , 8 go de ram et un gtx760/2govram ...même résultat. Les textures sont mal chargées après 5 min en dx11 et ça fonctionne un peu mieux en dx9 mais les textures mettent quand même du temps a se charger (mais au moins elles se chargent).

(L'astuce pour forcer les dx11 natif est a priori plus bonne.)

Reste plus qu'a espérer qu'ils corrigent ce bug visuel désagréable qui est quand même assez rédhibitoire pour un jeu qui met en avant ses qualités graphiques... maintenant il est aussi possible que l'open beta fasse tourner une version dégradée , ça c'est déjà vu des mmo qui tournaient mal en beta et hop d'un coup mieux a la realease... à suivre donc.




Kaeril
Alpha & Oméga
 
Je ne sais pas si le coup du DX11 natif fonctionne ou non, mais en tout cas suivre l'ensemble du procédé a au moins réglé ce problème de textures chez moi.
Avatar de Ardaan Serus
Ardaan Serus
Dieu / Déesse créateur/trice
 
Avatar de Ardaan Serus
 
Citation :
Publié par Alindiras
Reste plus qu'a espérer qu'ils corrigent ce bug visuel désagréable qui est quand même assez rédhibitoire pour un jeu qui met en avant ses qualités graphiques... maintenant il est aussi possible que l'open beta fasse tourner une version dégradée , ça c'est déjà vu des mmo qui tournaient mal en beta et hop d'un coup mieux a la realease... à suivre donc.
C'est surement Nvidia qui chie dans la colle avec son pilotes puisque sous AMD ça fonctionne normalement sans besoin de faire quoi que se soit.

Et donc très peu probable également pour la "version dégradée".
Avatar de Gaelynn
Gaelynn
Alpha & Oméga
 
Avatar de Gaelynn
 
J'ai une carte graphique AMD haut de gamme (R290x), avec proc et ram de qualité, et j'ai exactement le même problème de textures gros pâté comme dans les screens du 1er post. J'ai essayé à peu près tout ce que je pouvais faire, y compris régler tout en basse qualité, supprimer le répertoire shader et j'en passe, ça n'a rien changé.
J'ai bien essayé la méthode du vrai DX11 mais je n'ai vu aucun changement ni amélioration d'aucune sorte... Du coup je suis vraiment dans une impasse, avec mes pilotes à jour etc.
Je vais réessayer la manip a la release mais sinon je ne vois pas. A noter que chez moi, les textures grossières apparaissent immédiatement dès que je suis log.
Avatar de Dominique DEBEVEC
Dominique DEBEVEC
Alpha & Oméga
 
Avatar de Dominique DEBEVEC
 
Bonjour,

Je n'y avais pas tellement prêté attention jusqu'à présent et en voyant la première image avec cette brume que parfois j'ai la même chose.

Vous dites que ce que je prenais pour de la brume voir une tempête de sable n'est qu'on beug graphique dû à ma GTX 560 TI ? - Bon je l'ai pas souvent, mais bon...

--
Avatar de Mackdolphin
Mackdolphin
Dieu / Déesse souverain(e)
 
Avatar de Mackdolphin
 
j'avais voulu augmenter l'antialiasing dans le panneau de config Nvidia et ca m'avait fait le meme Bug, j'ai donc TOUT laissé géré par le jeu et desactivé le panneau de config nvidia et hop les textures sont redevenue net ! ne surtout pas augmenter le mipmap ou le FXAA
Avatar de Alindiras
Alindiras [E.D.R]
Roi
 
Avatar de Alindiras
 
Citation :
Publié par Mackdolphin
j'avais voulu augmenter l'antialiasing dans le panneau de config Nvidia et ca m'avait fait le meme Bug, j'ai donc TOUT laissé géré par le jeu et desactivé le panneau de config nvidia et hop les textures sont redevenue net ! ne surtout pas augmenter le mipmap ou le FXAA
J'ai noté aussi une incompatibilité avec les réglages du panneau nvidia... et je ne suis pas sur a 100% mais il me semble que ce bug est apparu/empiré après avoir ajouté Archage dans la liste des jeux gérés par le driver....

Pour la release je vais supprimer la référence Archage du panneau Nvidia et voir si ça ne marcherait pas mieux à tout hasard....

Avatar de aXolo
aXolo
Comte / Comtesse
 
Avatar de aXolo
 
Citation :
Publié par Alindiras
J'ai noté aussi une incompatibilité avec les réglages du panneau nvidia... et je ne suis pas sur a 100% mais il me semble que ce bug est apparu/empiré après avoir ajouté Archage dans la liste des jeux gérés par le driver....

Pour la release je vais supprimer la référence Archage du panneau Nvidia et voir si ça ne marcherait pas mieux à tout hasard....
Je pense comme toi ! Après avoir fait les modifications dans le panneau de config. Nvidia, le flou (en sprint) devient marron et certaines choses choquent ! Je l'ai donc enlevé, à voir demain maintenant...
Icanebal
Baron / Baronne
 
Salut à tous,

J'ai le même soucis !

J'ai fait déjà tout ce que vous avez fait.

J'ai même utilisé nvidia.inspector qui permet de changer les settings plus en profondeur.

Rien à faire. Toujours ce bug de textures.

J'ai dû cumuler sans mentir 8 heures dessus.

J'en ai ma claque, j'ai jamais passé autant de temps à gérer des problèmes graphiques sur un jeu.

J'ai l'accès anticipé j'ai quasi pas pu en profiter pour le moment...

Il faut dire qu'à la base j'avais un problème de FPS qui chutait gravement. Le jeu tournait avec le chipset du pc portable. Impossible de changer le processeur et prendre celui de Nvidia.

C'est comme ça que j'ai connu nividia.inspector qui m'a permis de supprimer le profile "Archeage" Nvidia et de prendre manuellement le fichier .exe. Ce n'est qu'ensuite que j'ai pu changer le processeur.

Et maintenant c'est les textures qui ne se chargent pas.

Le pire c'est que j'avais réussi à régler le problème mais au bout d'un moment dans le jeu, genre bien 10 à 15 minutes de jeu, certaines textures ne se chargent pas puis ça devient de pire en pire.

Bref. Si quelqu'un a réussi à trouver un truc, je suis preneur


EDIT : Pour l'info, j'ai deux ordis qui utilisent Nvidia. Sur l'autre je n'ai aucun soucis. La seule différence entre les deux sont la carte graphique, le fait que ce soit une tour et pas un portable, ET la mise à jour de la carte graphique.

Sur la tour je n'ai pas encore mis à jour ma carte graphique qui est "GeForce 337.88". La mise à jour du Portable est la plus récente. Donc on va essayer de downgrade la mise à jour. Je vous tiens au courant...

Dernière modification par Icanebal ; 14/09/2014 à 13h16.
Avatar de Hyspaen
Hyspaen
Marquis / Marquise
 
Avatar de Hyspaen
 
Essayez en supprimant le fichier cache, qui se situe pour ma pars C:\Users\xxxx\Documents\ArcheAge\USER\shaders

Ça règle pas mal de soucies de textures.
Icanebal
Baron / Baronne
 
Le downgrade de mise à jour n'a servi à rien...
Répondre

Connectés sur ce fil

 
1 connecté (0 membre et 1 invité) Afficher la liste détaillée des connectés

Rechercher
Rechercher:

Recherche avancée

Le wiki ArcheAge RSS
Les critiques d'ArcheAge RSS

© JeuxOnLine / JOL. Tous droits réservés. - Conditions générales d'utilisation - Conditions d'utilisation des forums - Politique de confidentialité - Utilisation de mes données personnelles - ! Signaler un contenu illicite