JeuxOnLineForumsPlusConnectés : 580 (sites) | 1168 (forums)Créer un compte
Forums divers
La Taverne
Répondre
Partager Outils Rechercher
Avatar de Mr_efbie
Mr_efbie
Roi
 
Avatar de Mr_efbie
 
Question

Partage Internet.

C'est assez désespéré mais bon...
Impossible de partager correctement ma connection internet :


J'ai un réseau entre 2 PC sous WinXP , ils sont connectés via un switch.
j'ai une connection adsl USB. Mon réseau fonctionne nickel, le partage de connection et de ressources aussi.
Malheureusement je ne peux accéder qu'a quelques sites : jeuxonline, google, msn.com, sourceforge.
les autres sites -> time out.

Le plus étrange est que msn et kazaa fonctionnent...

Encore plus étrange, j'arrive a faire un ping et un traceroute sans problèmes sur n'importe quel site.

le probleme subsiste si je change la connection de pc...

J'ai déja reformaté et ça n'a pas aidé...
Lien direct vers le message - Vieux
Avatar de Lemuel
Lemuel
Alpha & Oméga
 
Avatar de Lemuel
 
Déjà essaye de ne pas trop compliquer ton réseau... quel intérêt d'avoir un switch pour 2 pc?
C'est rajouter du matériel (donc une source de problèmes plausible) alors qu'un simple cable croisé pourait faire l'affaire.
Essaye déjà avec un câble croisé pour voir ce qu'il en est si le problème persiste. Mais c'est sûr que c'est étrange le fait que certains sites te soient accessibles et d'autre non.

Ton switch fait office de routeur en même temps? (je ne parle pas des routeurs comme dans les grosses compagnies, ceux qui ne servent qu'à créer les routes entre les pc, mais bien des routeurs pour les partages de connexion ici). Si c'est le cas, vois si certaines adresses ne sont pas bloquées.

Tu as un firewall? Hardware? Software (Zone alarm et compagnie)? Cela peut être une source de problème également, un firewall mal configuré peut bloquer pas mal de choses (c'est son but à la base).
Lien direct vers le message - Vieux
Avatar de Moine Gourmand
Moine Gourmand
Alpha & Oméga
 
Avatar de Moine Gourmand
 
C'est sûrement un problème de MTU (j'ai eu le même), essaie de corriger avec ce logiciel (http://surfoo3.free.fr/TCPOptimizer.exe) tu prends les réglages optimisé qu'il te donne et ce, sur les 2 PC (au moins pas de problèmes là)
Lien direct vers le message - Vieux
Avatar de Mr_efbie
Mr_efbie
Roi
 
Avatar de Mr_efbie
 
en fait, le cable croisé c'est pas pratique : étant donné la distance qui sépare les 2 pc, on a du installer un cable "définitif". ( 30m, passe a travers plusieurs murs et pièces ) et comme un portable va bientot arriver, on a préférer mettre directement du cablage droit et un switch.

le switch ne fait pas routeur.
Il n'y a pas de firewall
Et c'est pas un probleme de MTU, j'avais déja essayé...

J'espérais surtout que quelqu'un ayant déja eu le probleme connaisse la solution...
Lien direct vers le message - Vieux
Avatar de Flybear
Flybear [ChdL]
Roi
 
Avatar de Flybear
 
Un pb qui m'a longtemps obsédé. Comme l'a dit Moine Gourmand, ça vient de la MTU.

La solution :

Sur le PC qui n'as PAS la connexion internet : Démarrer ==> exécuter ==> regedit

La dedans il faut aller dans Poste de travail\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Tcpip\Paramaters\Interfaces\

La tu as plusieurs dossiers, il faut trouver celui qui correspond a ton adresse ip (a priori DhcpIPAddress : 192.168.0.X où x<>1)

La dedans clic droit ==> ajouter une nouvelle valeur Dword que l'on appelle MTU

Apres clic droit sur la valeur MTU ==> Modifier et lui mettre une valeur inférieure a 1500 (en décimal). Pour ma part je met 1454 et ça a marché a tous les coups. Sinon suffit de faire des tests en réduisant la valeur de 8 a chaque fois.

Y'a plus qu'a rebooter et normalement c bon

edit : lien permettant de calculer la mtu a mettre
J'avais plus al ligne de commande en tête. Par ailleurs je viens de m'apercevoir que pour mon reseau en fait avec 1454 ca passe pas, j'avais mis 1254, es-tu sur d'avoir suffisament la valeur de la mtu pour dire que ca ne vient pas de là ? Parceque les symptomes que tu décrit ressemblent furieusement au réglage de la mtu
Lien direct vers le message - Vieux
Avatar de Mr_efbie
Mr_efbie
Roi
 
Avatar de Mr_efbie
 
yeah ! ça marche !
le programme TCP optmiser ne mettait pas la clef au bon endroit

je ne te remercierai jamais assez !
je me suis arraché les cheveux sur ce truc pendant une bonne semaine !

Pour info, ça vient d'ou ce truc "MTU" et ça sert a quoi ?
Lien direct vers le message - Vieux
Avatar de Jio / Vani
Jio / Vani
Empereur / Impératrice
 
Avatar de Jio / Vani
 
je sais plus exactement.. mais en gros c'est la taille limite des paquets qui passent par le réseau... si ton second pc (qui n'est pas directement connecté à internet) a un MTU trop élevé il va essayer de récupérer des paquets qui ne pourront pas transiter par le premier pc çar son MTU est inférieur, c'est comme si on voulait faire passer une cassette vidéo dans un lecteur dvd ... ca coince. (désolé pour cette métaphore pitoyable)
Lien direct vers le message - Vieux
Avatar de Actarus78
Actarus78
Alpha & Oméga
 
Avatar de Actarus78
 
Un ptit analyseur TCP/IP pour voir si sa connexion est bien optimisée:
http://www.speedguide.net/analyzer.php

et de quoi l'optimiser (on y retrouve en autre le réglage du MTU):
http://www.speedguide.net/read_articles.php?id=157
Lien direct vers le message - Vieux
Répondre

Connectés sur ce fil

 
1 connecté (0 membre et 1 invité) Afficher la liste détaillée des connectés

Outils Rechercher
Rechercher:

Recherche avancée

Thème visuel : Fuseau horaire GMT +2. Il est actuellement 11h14.
   

© JeuxOnLine, le site des MMO, MMORPG et MOBA. Tous droits réservés. - Conditions générales d'utilisation - Conditions d'utilisation des forums - Traitement des données personnelles - ! Signaler un contenu illicite