JeuxOnLineForumsPlusConnectés : 230 (sites) | 383 (forums)Créer un compte
Dark Age of Camelot
Technique et Automatisation
Les forums JOL > Dark Age of Camelot > DAoC - Technique et Automatisation > LD et message d'erreur Windows RSS
   
Répondre
Partager Outils Rechercher
Avatar de misstoo
misstoo [OGS]
Reine
 
Avatar de misstoo
 

LD et message d'erreur Windows

Bonjour a tous

Voilà j'ai un problème que j'ai du mal à résoudre, apparemment ca a pas du arriver souvent parce que même Goa ne peut pas m'aider. Quand je joue sous SI, je lag énormément et un message d'erreur windows m'éjecte du jeu et me fait revenir sous le bureau. D'habitude, il faut attendre un moment avant de pouvoir se relog ( deconnexion du compte en cours), mais là aucun problème. Je LD au bout de 5 minutes. Je joue donc sous DAOC et je n'ai aucun problème.

Ma configuration

Proc AMD 2,4 G
CG ATI Radeon 9000
512 de RAM

Ca commence a plus être marrant du tout Si quelqu'un a connu ca ca serait sympa de m aider. Le message de windows est un truc du style "runtime error R6025 pure virtuall function call".

Voilà, merci de votre aide
Lien direct vers le message - Vieux
Avatar de Niki
Niki [Thana]
Bagnard
 
Avatar de Niki
 
heu, tu tournes sous quel windows stp ?
Lien direct vers le message - Vieux
Avatar de misstoo
misstoo [OGS]
Reine
 
Avatar de misstoo
 
windows XP Pro
Lien direct vers le message - Vieux
Avatar de Paice
Paice [SVPPB]
Alpha & Oméga
 
Avatar de Paice
 
Euh voilà rapidement quelques éléments de réponse :


Citation:
PRB: Cause of the R6025 Run-Time Error
The information in this article applies to:
Microsoft Visual C++ 1.0
Microsoft Visual C++ 1.5
Microsoft Visual C++ 1.51
Microsoft Visual C++ 1.52
Microsoft Visual C++ 2.0
Microsoft Visual C++ 2.1
Microsoft Visual C++ 4.0
Microsoft Visual C++, 32-bit Enterprise Edition 5.0
Microsoft Visual C++, 32-bit Enterprise Edition 6.0
Microsoft Visual C++, 32-bit Professional Edition 5.0
Microsoft Visual C++, 32-bit Professional Edition 6.0
Microsoft Visual C++, 32-bit Learning Edition 6.0

This article was previously published under Q125749
SYMPTOMS
The C++ program fails, and reports the following run-time error:

runtime error R6025
- pure virtual function call
CAUSE
This error occurs when your application indirectly calls a pure virtual member function in a context where a call to the function is not valid. In most cases, the compiler detects this and reports the error when building the application. But depending on how your code is written, sometimes the problem is detected only at run-time.

The error occurs when you indirectly call a pure virtual function within the context of a call to the constructor or destructor of an abstract base class. This is illustrated in the sample code below, along with some more description.
RESOLUTION
Calling a pure virtual function is a programming error, so you need to find the call to the pure virtual function and rewrite the code so it is not called.

One way to find a call to a pure virtual function is to replace the pure virtual function with an implementation that calls the Windows API function DebugBreak(). When using the debugger, DebugBreak() will cause a hard-coded breakpoint. When the code stops running at this breakpoint, you can view the callstack to see where the function was called.
STATUS
This behavior is by design.
MORE INFORMATION
For more information, refer to the "C Run-Time Errors R6002 through R6025" chapter of the "Build Errors" book included with Visual C++ 32-bit Edition, version 4.0, Books Online or search the Books Online for "R6025."

NOTE: The R6025 error is not documented in the manuals or online help included with Visual C++, versions 2.x or below. However, it is briefly discussed in Part 3 of the README.WRI file shipped with Visual C++ version 2.0.
Bon, en gros, c'est un problème de dev normalement mais comme nous n'avons pas l'erreur, c'est soit un problème avec ton runtime C++, soit un problème lié a un fichier dans le jeu lui même. A mon sens, la première chose que je ferais, c'est de réinstaller le jeu, désolé pour cette réponse en demi teinte, mais je n'ai que ça en tête pour le moment.
Lien direct vers le message - Vieux
Avatar de misstoo
misstoo [OGS]
Reine
 
Avatar de misstoo
 
Ben je l'ai deja fait mais c'est vrai que quand le message d'erreur s'affiche il me donne l'adresse d'un fichier SI. Je vais essayer de re re installer et je verrai bien. Merci de m'avoir répondu j'espère que ca va marcher
Lien direct vers le message - Vieux
Avatar de misstoo
misstoo [OGS]
Reine
 
Avatar de misstoo
 
J'ai réinstallé SI pleine d'espoir. J'ai tourné nickel pendant 2 heures, pas de lag, tout était ok. Puis re ld 2 fois de suite et hier soir pareil, c'est tjs un message d'erreur de Windows qui me fait ld mais je ne le vois pas s'afficher. Le jeu se bloque je dois en sortir avec la touche Esc.

Je n'ai toujours aucun problème avec Daoc normal, le problème ne se pose que sous SI, ce qui commence sérieusement à me rendre tristounette.

Si quelqu'un a un élément de réponse, je suis preneuse
Lien direct vers le message - Vieux
liltian
Roi
 
tu as essayé de tester ta RAM? et tes drivers sont-ils à jour? ca vient peut etre de là aussi
__________________
[img]http://******************/liltian/images/divers/signature.jpg[/img]
Lien direct vers le message - Vieux
Mystiki [OdP]
Roi
 
t'inkiete t pas seule
moi aussi ca m'arrive, ma config :
celeron 2 Ghz
ATI Radeon 9000 Pro
512 Mo RAM
Windows Me

(je précise que ca ma faisait exactement la meme chose avec windows Xp Pro)

je pense que ca doit venir de la carte grafike
Lien direct vers le message - Vieux
liltian
Roi
 
et que voit-on dans les notes de 1.62? correction d'un bug avec les ati 9000 et supérieures (après je sais pas si c ce bug)

essayez aussi de passer aux derniers catalyst


et quittez moi windows ME plus vite que ca!
__________________
[img]http://******************/liltian/images/divers/signature.jpg[/img]
Lien direct vers le message - Vieux
Mystiki [OdP]
Roi
 
g le tout dernier catalyst, et le bug avec ATI c le bug avec les tete des perso ou on voit des cheveu a la place des tete et les bug des caskes
en gros c pas ca le probleme réglé

pi g un autre probleme, quand ca ld pas avec le message d'erreur, ca me renvoie directement a windows
Lien direct vers le message - Vieux
liltian
Roi
 
ah bon ben dsl alors
Lien direct vers le message - Vieux
Avatar de misstoo
misstoo [OGS]
Reine
 
Avatar de misstoo
 
De mon côté ca fonctionne mieux depuis ke j'ai reinstalle Si, je ld au bout de 2h avant c etait au bout de 10 minutes Je viens de reinstaller mes anciens drivers avec lesquels ca fonctionnait très bien, j'ai pas eu le temps d'aller voir si ca fonctionnait ( boulot oblige ) mais j'en saurai plus ce soir.

Pour ma part j ai windows XP Pro. Le problème c'est que quand je ld je ne vois meme pas le message d erreur ( je l'entends en revanche) et je ne sais donc pas de quoi ca vient. Je suis renvoyée sous windows, par contre je peux me relog tout de suite alors que normalement il faut un moment avant que le compte se déconnecte. En fait on se fait carément éjecter de daoc ( il a une indigestion le pauvre lol ). J'espère que ca fonctionnera ce soir, meme a la FAQ ils ont pas pu m aider vous etes mon dernier espoir
Lien direct vers le message - Vieux
Mystiki [OdP]
Roi
 
bon bah je v faire comme toi alors, on sait jamais
cet aprem g ld 3x a 5min d'intervalle en prise de fort
si qq'un aurai une réponse svp
Lien direct vers le message - Vieux
Avatar de misstoo
misstoo [OGS]
Reine
 
Avatar de misstoo
 
Bon ben rien à faire, Si ne veut décidemment pas marcher, j'ai réussi a tenir un moment mais une fois ke j'ai ld après c'est de plus en plus fréquent... J'en peux plus là
Lien direct vers le message - Vieux
Avatar de Jashugan
Jashugan
Roi
 
Avatar de Jashugan
 
En vrac et au vu de l'erreur qui se produit aleatoirement et au bout d'un certain temps.

- Te reste t'il assez de place sur ta partition c: pour la memoire virtuelle ? (Panneau de config,systeme,avancé,options de performances,memoire virtuelle)

- Apparement cette erreur peut etre egalement provoqué par un conflit d'IRQ. DAOC fesant surtout appel a tes cartes video/son/reseau je regarderais si il n'y en a pas deux qui se partagent un meme IRQ.

- Quel est le message d'erreur exact ? Quel est le nom de fichier donné ? Ce message d'erreur provient t'il de camelot.exe ou d'un autre programme ?
Lien direct vers le message - Vieux
Répondre
Les forums JOL > Dark Age of Camelot > DAoC - Technique et Automatisation > LD et message d'erreur Windows
   

Outils Rechercher
Rechercher:

Recherche avancée

Les vidéos de Dark Age of Camelot RSS
Les critiques de Dark Age of Camelot RSS
Thème visuel : Fuseau horaire GMT +1. Il est actuellement 07h02.
   

© JeuxOnLine, le site des MMO, MMORPG et MOBA. Tous droits réservés. - Conditions générales d'utilisation - Conditions d'utilisation des forums - Traitement des données personnelles - ! Signaler un contenu illicite